4 Replies Latest reply on Sep 18, 2014 6:51 PM by b_ben

    Lightroom 5.5 - still not recognizing duplicates on import

    rleidy

      With so many people complaining about this issue, I can't believe that it hasn't been addressed in any version 5 update yet.  Version 4 did not exhibit this problem.

      Scenario:

      • Insert SD card containing many previously imported images and a few new ones.
      • Lightroom recognizes card and automatically switches to import
      • When configured to show new photos and with “Don’t import suspected duplicates” checked, many, many previously imported images on the card are shown in the import panel.
      • Wait a while for Lightroom to hopefully prune the set of duplicates.....nope.
      • Cancel the import, and without removing the SD card, re-initiate the import.
      • Magically, Lightroom does much better, but might still not recognize some duplicates.
      • Cancel the import, and without removing the SD card, re-initiate the import.
      • Usually, all duplicates have been recognized and just new photos are shown.

       

      It seem the longer the card is left in slot (built-in reader in the iMac), the more likely it is that Lightroom will recognize duplicates.  I'd welcome any advice on how to get my Lightroom 4 behavior back.

        • 1. Re: Lightroom 5.5 - still not recognizing duplicates on import
          DdeGannes Adobe Community Professional

          Are there files on the SD card that you previously imported and then subsequently removed/deleted from the Lightroom Catalog?

          • 2. Re: Lightroom 5.5 - still not recognizing duplicates on import
            rleidy Level 1

            No.  If that were the case, LR should show them consistently as needing to be re-imported.   But, that's not happening.  If I start/cancel the import enough times, I will ultimately get the correct behavior with the import screen showing only the new images on the card.

            • 3. Re: Lightroom 5.5 - still not recognizing duplicates on import
              Andy Aronson

              I'm having the same problem with LR 5.6. There seems to be no consistency as to when the issue occurs. It doesn't depend on if I removed images from the catalog on a previous culling session or not. Example: I recently imported 1166 images of a sporting event. I deleted a few hundred images from the catalog and from the external drive that the images were copied to during the import. When I went to check the contents of that CF card by using the import function of LR, all the images showed up as not having been imported, even though "Don't import suspected duplicates" was checked. I would have expected to see a few hundred to show up as not having been imported (those previously deleted from the catalog and external drive) but not all of them which includes the ones I saved in the catalog and on the external hard drive. Another CF card had several hundred images (all JPGs) of a different sporting event. They had all been imported into LR. None had been removed from the catalog or from the copy-to external hard drive. The next day they all showed as not having been imported despite "Don't import suspected duplicates" being checked.

              Until now, I hadn't realized that this was a chronic problem with the recent versions of LR.

              Thanks for any help anyone has to offer.

              Regards,

              Andy

              • 4. Re: Lightroom 5.5 - still not recognizing duplicates on import
                b_ben

                I have the same issue, but I only noticed since I switched from Windows to Mac OS. I never had this issue on Windows, but I get it all the time on mac. I don't know if it's related.

                 

                Regards,

                Ben