1 Reply Latest reply on Apr 22, 2007 5:28 AM by GMina

    No services-config.xml file

    silvalex
      What is the process that installs this file on my server? I dont have this file in my web directory
        • 1. Re: No services-config.xml file
          GMina Level 1
          are you running flex data services, or just using the Flex SDK? If you are just using the SDK (or Flex Builder) than you don't need to have the file on your server. It just needs to be available during compile-time.

          If you are using ColdFusion keep reading...
          I included a ColdFusion services-config.xml file below. You would just need to replace [INSERT YOUR URL] with your actual CF server URL. You could copy this file locally to your MXML components and include the path in the compiler options using the

          -services "c:\fullpath\to\services-config.xml"

          compiler switch.

          **** SERVICES-CONFIG.XML *****
          <?xml version="1.0" encoding="UTF-8"?>
          <services-config>
          <services>
          <service id="coldfusion-flashremoting-service"
          class="flex.messaging.services.RemotingService"
          messageTypes="flex.messaging.messages.RemotingMessage">

          <adapters>
          <adapter-definition id="cf-object" class="coldfusion.flash.messaging.ColdFusionAdapter" default="true"/>
          </adapters>

          <destination id="ColdFusion">
          <channels>
          <channel ref="my-cfamf"/>
          </channels>
          <properties>
          <source>*</source>
          <!-- define the resolution rules and access level of the cfc being invoked -->
          <access>
          <!-- Use the ColdFusion mappings to find CFCs, by default only CFC files under your webroot can be found. -->
          <use-mappings>false</use-mappings>
          <!-- allow "public and remote" or just "remote" methods to be invoked -->
          <method-access-level>remote</method-access-level>
          </access>

          <property-case>
          <!-- cfc property names -->
          <force-cfc-lowercase>false</force-cfc-lowercase>
          <!-- Query column names -->
          <force-query-lowercase>false</force-query-lowercase>
          <!-- struct keys -->
          <force-struct-lowercase>false</force-struct-lowercase>
          </property-case>
          </properties>
          </destination>

          </service>
          </services>

          <channels>
          <channel-definition id="my-cfamf" class="mx.messaging.channels.AMFChannel">
          <endpoint uri=" http://[INSERT YOUR URL]/flex2gateway/" class="flex.messaging.endpoints.AMFEndpoint"/>
          <properties>
          <polling-enabled>false</polling-enabled>
          <serialization>
          <instantiate-types>false</instantiate-types>
          </serialization>
          </properties>
          </channel-definition>
          </channels>

          <logging>
          <target class="flex.messaging.log.ConsoleTarget" level="Error">
          <properties>
          <prefix>[Flex] </prefix>
          <includeDate>false</includeDate>
          <includeTime>false</includeTime>
          <includeLevel>false</includeLevel>
          <includeCategory>false</includeCategory>
          </properties>
          <filters>
          <pattern>Endpoint.*</pattern>
          <pattern>Service.*</pattern>
          <pattern>Configuration</pattern>
          <pattern>Message.*</pattern>
          </filters>
          </target>
          </logging>

          <system>
          </system>

          </services-config>