4 Replies Latest reply on Apr 20, 2007 1:17 PM by kglad

    PLEASE HELP--gotoandPlay plays through frames I dont want it to.

    Goy972@aol.com
      Hello--I am an architecture student and I am having problems with my Flash website. I have uploaded my half-done website on
      http://ilocker.bsu.edu/users/msgoyak/WORLD_SHARED/

      My animations end on frame 311, where I have five buttons linking to different frames (The Resume button links to 312 and the About Me button links to 313 using
      on (release) {gotoAndPlay(frame number);

      }
      I also have "back" buttons on 312 and 313 which link back to 311. All three frames have the stop command applied.
      My problem: Whenever I publish and try to click on Resume or About Me, it will only play to 312 due to the stop command, thereby not allowing me to get to the About Me frame (313). I have tried taking away the stop command but then when I click on the About Me button the timeline plays through 312 to get to 313 and you can actually see it flash through on-screen. I just want ithese buttons to jump to their respective frames and stop, without seeing anything in-between or stopping where it shouldn't. Is there a specific actions script that needs to be applied or would it be easier to create new flash documents for each link?

      Hopefully someone can help m after viewing the website itself.
      I have version 7 MX 2004.
      Thank you if you can provide any feedback!!!!!! Hopefully this frustration thing can be corrected.
        • 1. Re: PLEASE HELP--gotoandPlay plays through frames I dont want it to.
          Level 7
          Use the gotoAndStop(frame number): instead of play.

          The playhead will stop on the disignated frame, and you won't need a stop
          action on it.


          "Goy972@aol.com" <webforumsuser@macromedia.com> wrote in message
          news:f0b17u$5ot$1@forums.macromedia.com...
          > Hello--I am an architecture student and I am having problems with my Flash
          > website. I have uploaded my half-done website on
          > http://ilocker.bsu.edu/users/msgoyak/WORLD_SHARED/
          >
          > My animations end on frame 311, where I have five buttons linking to
          > different
          > frames (The Resume button links to 312 and the About Me button links to
          > 313
          > using
          > on (release) {gotoAndPlay(frame number);
          >
          > }
          > I also have "back" buttons on 312 and 313 which link back to 311. All
          > three
          > frames have the stop command applied.
          > My problem: Whenever I publish and try to click on Resume or About Me, it
          > will
          > only play to 312 due to the stop command, thereby not allowing me to get
          > to the
          > About Me frame (313). I have tried taking away the stop command but then
          > when I
          > click on the About Me button the timeline plays through 312 to get to 313
          > and
          > you can actually see it flash through on-screen. I just want ithese
          > buttons to
          > jump to their respective frames and stop, without seeing anything
          > in-between or
          > stopping where it shouldn't. Is there a specific actions script that
          > needs to
          > be applied or would it be easier to create new flash documents for each
          > link?
          >
          > Hopefully someone can help m after viewing the website itself.
          > I have version 7 MX 2004.
          > Thank you if you can provide any feedback!!!!!! Hopefully this frustration
          > thing can be corrected.
          >
          >


          • 2. Re: PLEASE HELP--gotoandPlay plays through frames I dont want it to.
            kglad Adobe Community Professional & MVP
            use _root.gotoAndStop(312) and _root.gotoAndStop(313).
            • 3. Re: PLEASE HELP--gotoandPlay plays through frames I dont want it to.
              Goy972@aol.com Level 1
              Thanks kglad...I dont know why the _root helps but it definitely works now! Thanks again!
              • 4. Re: PLEASE HELP--gotoandPlay plays through frames I dont want it to.
                kglad Adobe Community Professional & MVP
                if your button is a movieclip button, using _root is necessary or you're referencing the movieclip button's timeline.

                if your button is a true button you may still have a problem if you're using scenes and you change the order of your scenes.