1 Reply Latest reply on Aug 5, 2014 11:41 AM by Peter Spier

    Large document causes InDesign to hang - Save as IDML etc. not possible

    PlainMartin Level 1

      I recently had what I can only call an InDesign nightmare. An important 150 page document I had been working on for months suddenly turned “self-destructive”. I could still open this document and even create PDFs from it, but almost every other action (for example, opening the find dialog or the spell checker) would result in InDesign not responding anymore. Upon restart, the document would be recovered - only to choke InDesign again whenever I tried editing it.


      I tried saving my work using the tricks that are often suggested in this situation: “Package”, “Save as” or “Save a copy” (in IDML format) to create a clean copy of the document without any digital cruft. Unfortunately, all of these commands would result in InDesign crashing or hanging as well.


      At this point, I tried to copy all (threaded) text from the document to a text-only document in BBEdit, a popular text/code editor. But even a simple “Copy” command would crash InDesign. An when I managed to copy a section of text from the InDesign document to BBEdit without InDesign going down immediately, BBEdit would hang, too - something that almost never happens; this is an incredibly robust editor.

       

      As a last resort, I created an empty InDesign document and moved chunks of content from the defect document there piece by piece. Whenever InDesign crashed, I realized I had come closer to the “land mine” in that doc.

       

      After several hours, it came down to one paragraph of text that could neither be edited or copied without InDesign hanging, so I simply rewrote that. Switching on invisible characters showed nothing except letters and spaces for this paragraph.

       

      So now I have saved my formatted content, but lost all master pages and other settings. And of course, I still don't know what happened in the first place...

       

      Has anyone ever experienced something similar? Is there another way out of this situation (where even exporting to IDML or using “Save as” isn't possible anymore)?

       

      It is only this one document that caused trouble, so I doubt trashing Preferences would help.

       

      Thanks!