1 Reply Latest reply on Jun 16, 2015 11:46 PM by DemelzaPoldark

    Unable to authorise digital editions

    Maybe-me

      I use digital editions to read books from my public library. Suddenly when it was downloading a borrowed book it gave my an error as follows: "Connection error detected - Digital Editions could not connect to the fulfillment server. Please make sure you are connected to the Internet". The internet is fine so I uninstalled Digital Editions and re-installed it. When I tried to authorize it it gave me the same error as above. I contacted my library who said I should switch my firewall off and try again. Did this and unfortunately it didn't help. Has anyone else had this problem and found a solution?

        • 1. Re: Unable to authorise digital editions
          DemelzaPoldark

          I started having the same problem this week.  ADE had worked fine until now.  Like you I started by not being able to connect to the fulfillment server.  I tried all the fixes, uninstalled, reinstalled, rebooted, nothing worked, couldn't deauthorize my computer so resorted to the control shift d option, that deauthorized, but then I couldn't authorize my computer, got the error could not connect to the activation server.  I went through all the uninstalling, reinstalling several times, and was getting very frustrated.  Finally I went into my admin account, ADE showed authorized there, tried to add a borrowed library book & it told me that I had to authorize, so I clicked on help, deauthorized, then authorized, the book transferred, plugged in my Kobo Glo & added the book to it.  When I logged off of my admin account & went back to the account I normally use, my ADE still shows that it isn't authorized & the book I added is not in my library.  So I guess I have to use it from my admin account on my computer.  It is kind of annoying, but at least I found a fix that actually worked for me.