0 Replies Latest reply on Aug 12, 2014 3:46 AM by cyclosdesign

    Elements twitching in Firefox when setting stage to responsive scaling


      I ran into a problem the other day on my first Edge Animate project.


      Here is a simplified version of my animation that should help explain it.




      I have a map with about a dozen of "objects", which consist of an icon and a text label each (combined into a symbol for easier handling),

      At the end of the animation, one object is set to bounce indefinetly by using a sim.play("marker"); trigger.


      Inline previews in Edge Animate look fine, but when using the browser preview, icons and text labels start to twitch randomly by 1-2 pixels –

      if the stage properties are set to "Responsive scaling".

      You may need to resize the browser window to see the effect.

      In my original file with 12 objects, at least 3-4 are twitching at any time.

      As far as I can tell, only Firefox is affected (Mac and Windows).

      I checked the symbols, there are no animation keyframes inside them.

      When the browser window is resized, the twitching objects and the direction of the effect change randomly as well.

      The twitch is synched to the bounce loop (but also noticeable sometimes when the animation starts and before reaching the loop trigger).


      Is there something I can do on my end to fix this or is this plainly a bug in connection with the Firefox rendering engine?

      Thanks for your feedback.


      Here's a zip with all the files from my example animation.