2 Replies Latest reply on Sep 5, 2014 11:39 AM by winstonsalser

    Flash Player won't install on OS 10.6.8 on Mac mini

    winstonsalser Level 1

      QUESTION:

       

      I need to use Mac OS X 10.6.8 in order to run software not supported in later versions of OSX.  I cannot succeed in installing the new versions of Flash Player in the Mac mini I need to use for this work.

       

      I have successfully installed the version 14 flashplayer on 10.9.3 systems running on the same Mac mini (on a different partition of the same HD).  I have also successfully installed the new Flash Player on a 10.6.8 system running on an iMac.  BUT I cannot do what I need: instal the new Flash Player on a 10.6.8 system running on my Mac mini (Serial # C07FC92JDD6H, build 10K549).  I have tried to install 14.0.0.145 on this computer many many times, and the install always stops, freezing at precisely 95%.  I have downloaded the 14.0.0.145 update from at least three different download sites, to deal with possibility of corrupted version.  Repeated Google searches show many others had similar problems installing the new Flash Player versions (on different platforms and frequently with OS versions other than 10.6.8), and I have eagerly tried to learn from their successes  but NONE have worked on my particular computer.  (Nor have I seen any case of someone experiencing a similar problem on a Mac mini, either without success or with later success).  When the latest version, 14.0.0.176 came out, I eagerly tried it again a few times, but also without success. 

       

      By the way, I should mention that my latest version of Flash Player on this Mac mini is 11.5.502.  Would it shed any light on my problem if I try installing intermediate versions (Flash Player 12 through 13) on my computer, to see if they hang up?  Is there any version other than 14 that would not be rejected on the web?

       

      I have two earlier model Mac minis that I could try installing 14.0.0.??  on if you think my consistent failures might be an idiosyncratic feature of the Mac mini whose serial number I gave above (and that the Flash player updates could work on either of the other two Mac minis).  I would gladly put the more recent model Mac mini aside if I could get the Flash Player install to succeed on one of my other Mac minis.

      Thanks for any suggestions you can suggest.

       

      Winston Salser, Professor of Molecular Genetics, UCLA

      Phone 310-459-3554, iPhone 510-421-2735, email: salser@earthlink.net

        • 1. Re: Flash Player won't install on OS 10.6.8 on Mac mini
          winstonsalser Level 1

          This is an update from Winston Salser. 

          I have discovered one answer to my original question. It is a "kludge" but it works.

           

          You can see above that I asked, among other things, if it might help for me to try installing earlier versions of Flash Player, such as Version 12 or 13.  While waiting for an answer to my question, I decided to go ahead and try installing an older version.  I was able to download version 13 from an Adobe site that has archived older Flash Player versions.  Before attempting to install it, I uninstalled the version(s) of flash Player currently on my computer.  The downloaded version 13, when I used the "get info" function, identified itself as "flashplayer_13_sa.dmg".   When I clicked on this .dmg installer it surprised me by producing an icon called "Flash Player.app"  which wasn't what I expected to happen from seeing earlier Flash installers. Not knowing anything better to do, I decided to run this app, (which "get info" describes as "Version 13.0.0.241").  I clicked on this application icon, and I think it was then that a FlashPlayer icon appeared in my dock.

           

          I assumed that Version 13 would be rejected, not allowing me to see videos because it presumably doesn't have the required security update. But, the plan I originally suggested was that, if it failed with the typical black screen, I would (as originally planned) again try to install version 14, hoping that somehow passing Version 13 through the bowels of my computer would have cleansed it so that Version 14 would now install.

           

          So, I was surprised that Version 13 actually allows me to see videos!! Whenever I click on a video I first briefly see the black screen with the message (I cannot remember what it says, but it is what you always see when it refuses to play a video, and says you are blocked).  Then, within a second or less, the black screen goes away and the video plays normally.  I have tried this on several videos, and so far I can always view the video just fine except for that very fleeting slap-in-the-face of the black screen.

           

          This is obviously a "kludge" but it works for me now, so that I can function.  It may be helpful for others with the same or similar problems.  It may be significant that the "Get Info" function indicates that this version 13 I downloaded August 16th, was last modified on "Monday, August 4, 2014 5:59 PM", so perhaps it has recently been modified to include the security update???

           

          It would be still better if there was a way I could successfully install version 14.  That is why I am not going to indicate that my original query has been successfully answered. I am hoping that the "real" experts (you know who you are) will either have a better answer, or tell me that my "kludge" shouldn't be used for some reason, or these experts will say that my kludge is OK and they don't have any way I can install Version 14.  In this last eventuality it will remain a mystery why Version 14 refuses to install on my Mini mac (as long as the Mac mini is using the OS 10.6.8 operating system, but installs OK if this Mac Mini is using OS 10.9.3).

           

          Thanks to all of you.   Winston

          • 2. Re: Flash Player won't install on OS 10.6.8 on Mac mini
            winstonsalser Level 1

            Three weeks ago I wrote that I had discovered a "kludge" that enabled me to see videos, even though I am still unable to install the version 14 flash player.  As I explained then, l accidentally discovered that downloading a standalone version 13  [I downloaded "flashplayer_13_sa.dmg", and, when I clicked, it did not go through the install routine, but instead produced an icon called "Flash Player.app".  Wondering what this was, I used "get info" that describes this as "Version 13.0.0.241"].  And for a while it seemed to work fine.

             

            More recently I find that this "kludge" works only a small pert of the time, so I have again repeatedly tried to install V14, with no better results than in my first inquiry.  (by that time my computer had several files related to earlier attempts, so I not only used uninstall, but also tracked down and deleted all files with flashplayer-related names, followed by a really "clean" install.

             

            Therefore, with my "kludge" failing, I really do not have a solution and cannot play videos  (For those of you who were able to easily update to V14, you may not know how a poor sinner like me is blocked, but you get a black screen with a small message demanding you install newest flashplayer).

             

            I am surprised that no one has responded to any of my requests for assistance. I will be grateful for any assistance, even if you only can suggest what my problem is (that is, please comment even if you do not have a solution). 

             

            To remind you why I need to use snowleopard (10.6.8), it is because I depend on some software which is not supported in any later version of the OS.  Therefore when I really need to do something requiring a flashplayer, I have to reboot from a partition (a partition on the same hard drive) with Maverick, or I have to go use one of my colleagues Macs that does have a functional flashplayer.  This is  enough of a pain that I usually just do without seeing what the Flashplayer police are preventing me from seeing

             

            Please at least tell me what you think is causing this problem, even if you don't have a solution. 

             

            Winston