2 Replies Latest reply on Aug 19, 2014 4:27 AM by MattyIngold

    photoshop is really broken, help please

    MattyIngold

      hi, i have had a problem for a while now and i am not really sure why.

      My problem is using the brush tool in Photoshop, while i am using it, it is fine, there are no problems but when i unclick to stop drawing on my trackpad and try to to scroll using two fingers on my trackpad nothing happens, my artwork doesn't move until i them command click back into the photoshop window, it then goes crazy and does all of the scrolling i tried to do before i command clicked back in.

       

       

      The same sort of thing is happening with a lot of the other tools, when i use the spot healing brush the area selected stays the dark grey colour until i command click back into photoshop then it will heal the area.

       

       

      The lasso tool shows the selection but does not start the marching ants until i command click again. The polygon lasso tool lags behind clicks, for example, when i click nothing happens, i then click again and nothing will happen, when i click for the third time the first two dots then connect, when i click again the next dots will connect but will never connect to the last dot until i click i join the shape up and click once more, which then makes the shape disappear.

       

       

      I am having the same sort of problem with the clone stamp tool, the history brush,  the eraser, the blur, sharpen, smudge, dodge, burn, sponge tools, i guess any tool that has a brush size. and all of the lasso tools. All of the other tools work fine to my knowledge.

       

       

      I think it has something to do with apples track pad, today i tried using a mouse and it worked fine, i could draw a line and then scroll with the little ball in the apple mouse and it worked fine, but when i drew a line on my trackpad then tried to scroll with the mouse it didn't do anything until i command clicked. i then tried to click with the mouse and use the trackpad to scroll and that also worked fine.

       

       

      Im currently using photoshop CC 2014 but i also had these issues in photoshop CC and i am pretty sure in photoshop CS6.

       

       

      I am using a macbook pro retina 15 these are the specs

      MacBook Pro   (Retina, 15-inch, Late 2013)

      Processor   2 GHz Intel Core i7

      Memory   8 GB 1600 MHz DDR3

      Graphics   Intel Iris Pro 1536 MB

       

       

      i also had the same problem with my 2012 Macbook pro 15.

       

       

      i have searched for an answer to this but i can't seem to find anything on the internet, i had uninstalled and reinstalled photoshop,  i have reset all of the tool preferences, and deleted all of photoshops preferences when that didn't do anything.

       

       

      any help would be very much appreciated

      thankyou

      Matty