0 Replies Latest reply on Aug 19, 2014 3:15 PM by John Welsh Screen Name

    After Effects CS6 error: RAM Preview needs 2 or more frames to playback - any ideas please?

    John Welsh Screen Name

      Hi everyone,


      I'm running After Effects CS6 ( on a MacBook Pro 2.8Ghz with 16GB RAM (Mac OS 10.9.4)


      As a test, I created a 3 and a half minute Sequence in Adobe Premiere CS6, and then imported this into After Effects CS6, and placed it on the AE timeline.

      This footage involves a couple of 1920x1080p footage movies, some psds and a large number of JPGs exported from two videos arranged as a sequence in two layers in Premiere, one on top of the other. So all in all for a Premiere / After Effects file I'd say it's reasonably heavy.


      I then did a RAM Preview with Multiprocessing switched off - the 3 and a half minute sequence loaded into RAM, taking about 1min 30seconds, and played back in realtime at 25fps. This worked fine with 3,4,5 and 6 GB RAM available to other applications in the Memory Preferences. All things considered I think this is quite good. I can make changes, reclick the RAM Preview icon and my changes load into RAM and it previews ok.


      My only 'complaint' is how long the RAM Preview takes to load up the whole thing.

      I've been reading up on Multiprocessing and decided to try this to see if I can speed up the time it takes my RAM Preview to load up.

      So I looked at some recommendations from Adobe and read information on various forums including this one.


      My settings in the Memory Preferences are currently

      • 6GB reserved for other applications

      • Reduce cache size when system is low on memory - unticked

      • After Effects Multiprocessing - ticked

      • Installed CPUs (processor cores) - 8

      • CPUs reserved for other applications - 6

      • RAM allocation per background CPU - 3GB

      • Actual CPUs that will be used - 2


      This combination takes about 25 seconds to load up my 3 and a half minute sequence which I thought was pretty amazing.


      I then pressed the stop button and then the play button - so now just playing the sequence briefly.

      And also added a new layer - into the timeline - just a simple shape.


      Then I tried a RAM Preview again.

      I found I could load up part of the sequence but not load the whole thing into RAM.


      I kept trying to get a RAM Preview and got this message

      "After Effects error: RAM Preview needs 2 or more frames to playback" which seems to prevent RAM Preview from working.


      Eventually I quit and restarted After Effects and the problem went away temporarily and then came back when I tried again.


      I tried various changes to the Memory Preferences - trying 3GB available for other applications. This gave 13GB of my 16GB RAM to After Effects.

      This made it take slightly longer for the After Effects error to appear but it still appeared.


      I tried ticking Reduce Cache size in the Memory Prefs  - the After Effects error still appeared, so having read this is supposed to make the issue better I now leave it untucked, but as far as I can see ticked or untucked, it makes no difference, the problem remains.


      I've since tried -

      Making 2,3,4,5 and 6 CPUs available for other applications.

      Changing the Background RAM allocation per background CPU to 0.75GB, 1GB, 1.5GB, 2GB and 3GB

      Lots of combinations.

      But in the end, I always get the "After Effects error: RAM Preview needs 2 or more frames to playback" error.

      It might take less or more time for the message to show up, depending on the combination of settings, but in the end I always got the same message appearing.

      And I notice that I can RAM Preview less and less of the timeline. i.e. it becomes more blue than it does green and will load in only a small section of the timeline as opposed to the whole thing.


      Reading further, I tried Edit > Purge > Image Cache and Edit > Purge > All Memory but still get the error message.


      I also tried ensuring there were no other applications running e.g. Safari or Chrome or Firefox. And certainly not Photoshop or Premiere etc.


      Reading even further, I tried two Memory management applications - 'Memory Clean' and 'Purge.'

      Neither has had any effect - the After Effects error still appears.

      Then I went back into the Memory and Multiprocessing Preferences.

      I unticked Render Multiple Frames Simultaneously. And now the RAM Preview loads the whole 3 and half minute sequence in entirety, taking about 1 and half minutes to do so. It's working as perfectly as if I'd just quit and re-opened the application.

      Then I went back into the Memory and Multiprocessing Preferences.

      I reticked Render Multiple Frames Simultaneously.

      The chose Edit > Purge > All

      And tried a RAM Preview again. It loaded up in 25 seconds, but then, as previously, the error message came.

      I tried Edit > Purge All - no effect.


      And I tried going into the Media and Disk Cache Preferences and clicked Empty Disk Cache - still the problem remains.


      I understand from my reading that After Effects CS6 11.0.2 was intended to fix this issue but I'm on 11.0.4 and as far as I can tell, I still have it - assuming it's the same thing.


      As far as I can see, not using Multiprocessing allows me to work without these errors but take a bit longer to load the RAM Preview.


      However I'd like to be able to use Multiprocessing as it seems it can potentially speeds things up quite a lot. I realise I could just not use it and AE would work, but I'd rather be able to make use of a feature of the software if possible, especially if it will speed things up and make optimum use of the my computer's hardware.


      I've downloaded a trial copy of After Effects CC 2014. I'm still testing it but as far as I can see the RAM Preview error appears in this version of AE as well, but can take bit longer to show up in my experience.


      Thanks everyone - if anyone has any thoughts or advice I'd appreciate hearing your opinions.


      Kind regards,