2 Replies Latest reply on Mar 12, 2015 9:34 AM by Gaius Coffey

    Font loading woes...

    Gaius Coffey Level 2

      Hi,

      I'm being driven nuts by something that I am certain is simple to resolve. We have hundreds of fonts in use, so are loading them on demand after compiling css to swf in Flash Builder.

       

      This worked fine for many years...

       

      We are in the midst of a fairly significant code upheaval and now, whatever I do, I get an error that blocks loading and (frequently) wipes out the Flash movie entirely;

       

      Error: Compatibility version has already been read.

        at mx.core::FlexVersion$/set compatibilityVersion()[E:\dev\4.y\frameworks\projects\framework\src\mx\core\FlexVersion.a s:282]

        at mx.core::FlexVersion$/set compatibilityVersionString()[E:\dev\4.y\frameworks\projects\framework\src\mx\core\FlexVer sion.as:329]

        at AntihistoryRegular_mx_core_FlexModuleFactory()

       

      I can find no clues on the web other than resources that point to the transition between Flex 3 and Flex 4... Something that is _long_ since been taken out of the mix in our case.

       

      Any pointers?

       

      Thanks,
      G