1 Reply Latest reply on Aug 23, 2014 7:13 PM by pwillener

    Need for speed - how absolute?

    Egtverchi

      I keep getting asked to install the new version, and my Mac exceeds all system requirements EXCEPT speed - the upgrade requires 1.83 GHz, and I only have a 1.7 GHz Intel Core i5. Does this mean I can't upgrade? What happens if I install the new version anyhow?