1 2 3 4 Previous Next 136 Replies Latest reply on Aug 30, 2017 11:45 PM by notbebe

    Unable to delete temporary files

    joshtbailey

      I am running Acrobat Reader 11.0.0 in a XenApp 6.5 Environment on Windows Server 2008 R2 SP1.  We have recently started using Mandatory profiles and the option set to delete cached profiles on logoff.  We have started noticing that some of the profiles are not being deleted because of files that are locked by the system.  The files are named Z@*.tmp.  I have done some research into the issue and have found an article on your website that mentions this issue specifically:

       

      http://blogs.adobe.com/dmcmahon/2011/11/08/acrobatreader-tmp-files-left-behind-in-temp-fol der-after-printing/

       

      Please note this article is dated 11/2011 and seems to refer only to XP, NT, and 2003 server.  Also at the bottom of the article it states the following:
      Following our testing we have discovered that the issue does not occur in Windows 7, or Windows 2008 Server.  It seems that the updated versions of Windows provide a solution to this issue.  We would therefore recommend updating your OS if possible.

      I have found that this is not that case and this issue seems to remain, at least in my configuration.

        • 1. Re: Unable to delete temporary files
          baja3740

          We are having the same issue and profiles cannot be cleaned up until reboot..  We have uninstalled Adobe 11.0.08 and gone backwards to 10.1.4 to test and see if this fixes the issue.

          • 2. Re: Unable to delete temporary files
            digitlman77 Level 1

            We are seeing the same issue with our Citrix 6.0 servers running on Windows 2008 R2.  I hope adobe fixes this soon.

            • 3. Re: Unable to delete temporary files
              joshtbailey Level 1

              Let me know if this fixes your issue.

              • 4. Re: Unable to delete temporary files
                Caorthann

                We are also experiencing this issue......

                 

                OS : Windows Server 2008 R1 x86 | Citrix Xenapp 6

                Occurred : After upgrading from Reader 11.0.07 to 11.0.08

                 

                Issue :

                When a user logs off, their roaming profile is normally deleted on the Citrix server. However, Adobe Reader s leaving a number of Z@R****.tmp files in Appdata\Local\Temp\<number>\ that are locked and cannot be deleted until the server is rebooted. This is preventing profiles from being deleted properly upon logoff.

                • 5. Re: Unable to delete temporary files
                  digitlman77 Level 1

                  I have not performed the work arounds as I do not want to lose print quality, and I feel Adobe need to fix it anyway.

                   

                  I logged a bug with Adobe to include PMon caps on the user logout to see if they can find what the problem is.  Have not heard a THING back.

                   

                  In the meantime, I remove a server every day from the farm, reboot it once empty, manually delete the user profiles, and put it back into the farm.

                   

                  Pain in the ***.

                  • 6. Re: Unable to delete temporary files
                    StefanSch

                    Hello,

                     

                    we have the same problem with

                    - Reader 11 on

                    - Windows Server 2008 R2 SP1 x64 using

                    - Citrix XenApp 6.5 Rollup Pack 4

                     

                    2 out of 7 users produce this problem every day, resulting in locked profile folders on all terminalservers daily.

                    We have to reboot the servers every day and delete folders manually aferwards.

                    • 7. Re: Unable to delete temporary files
                      rhservices

                      Dear all,

                       

                      do you have installed windows security updates which have been released at 27th of August 2014?

                       

                      May the following Hotfix is the problem: Microsoft Security Bulletin MS14-045 - Important

                       

                      KB Article: http://support.microsoft.com/kb/2984615

                       

                      At the moment I have the problem I can't uninstall the Hotfix to confirm my assumption, but ít seems that all problem have begun at september and that Hotfix could be the trigger for that symptoms.

                       

                      With kind regards

                      • 8. Re: Unable to delete temporary files
                        StefanSch Level 1

                        Thank you for the info!

                        We do have KB2993651 installed and the problem started around that time.

                         

                        Microsoft says:

                         

                        Known issue 1

                        After you install this security update, fonts that are installed in a location other than the default fonts directory (%windir%\fonts\) cannot be changed when they are loaded into any active session. Attempts to change, replace, or delete these fonts are blocked, and a "File in use" message is displayed.

                        http://support.microsoft.com/kb/2993651/en-us

                         

                        I have uninstalled the update on a server now. As soon as I am able to restart it and have watched it for a day, I will come back with the results (if any).

                         

                        Regards, Stefan

                        • 9. Re: Unable to delete temporary files
                          StefanSch Level 1

                          Unfortunately this did not help. After uninstalling KB2993651 and rebooting the server on tuesday, I today have two locked local profile folders on that server again, with a date of yesterday.

                           

                          I will try uninstalling KB2976897 now.

                          • 10. Re: Unable to delete temporary files
                            Caorthann Level 1

                            Uninstalling KB2993651 and rebooting the Citrix server did fix the issue for us

                             

                            The process I used to verify this was:

                            1. Cleaned up profiles

                            2. Uninstalled KB2993651

                            3. Rebooted server

                            4. Logged in and opened C:\Users\<Username>\Appdata\Local\Temp\<number>\

                            5. Opened a PDF and printed it - watched the Z@*.tmp files be created in temp folder

                            6. Closed Adobe Reader - watched Z@*.tmp files be deleted.   (Historically, the files were not deleted upon closing Adobe Reader)

                            7. Logged off - confirmed that the profile was indeed deleted.

                             

                            On Citrix servers that still have KB2993651, I can repeat these steps but the Z@*.tmp files are not deleted upon closing Adobe Reader.

                            On a different server, I tried installing Adobe Reader 11.0.09 without removing KB2993651 and the issue was still present so .09 did not resolve the issue.

                            • 11. Re: Unable to delete temporary files
                              StefanSch Level 1

                              Are you sure it was Z@*.tmp files and not A*.tmp files?

                              I have seen temp files being created and successfully cleaned after printing a PDF as you just did, but they didnt have the Z@*.tmp names.

                               

                              I followed these steps now:

                              1. Uninstalled KB2976897 aswell (KB2993651 was uninstalled before)

                              2. Rebootet server

                              3. Cleaned old local profiles under C:\Users

                              4. Logged in as user and printed a PDF to a real printer (-> Z@R*.tmp files were being created)

                              5. Closed AcrobatReader (-> temp files are still there and locked)

                              6. Logged off the server (-> local profile is not deleted)

                               

                              But I noticed, that only some PDF files (with a lot of fonts included) produced Z@*.tmp files. Other dont create any temp file in that location (scanned images, no fonts included). Others again create A*.tmp files, wich are deleted when closing AcrobatReader.

                               

                              The problem occurs when being a domain administrator aswell.

                              • 12. Re: Unable to delete temporary files
                                Caorthann Level 1

                                It appears to vary from PDF to PDF ... I do see the A*.tmp files created along with the Z@*.temp files when printing some PDFs. However, the A*.tmp files are being deleted when Acrobat Reader closes whereas the z@*.tmp files do not delete on the servers that still have the KB2993651 update.

                                • 13. Re: Unable to delete temporary files
                                  HKerat

                                  We are still on Reader 11.0.0.7 but have installed Microsoft KB2993651. Same problems here since installing MS Update.

                                  • 14. Re: Unable to delete temporary files
                                    pinkadmin

                                    @StefanSch, could it be that you only uninstalled KB2993651, while it's predecessor KB2982791 is still installed on the system? If this is the case I assume you have to uninstall KB2982791 as well before the problem indeed is solved.

                                     

                                    @Caorthann, great to see you are having more success. Did you have to uninstall KB2976897 as well?

                                    • 15. Re: Unable to delete temporary files
                                      StefanSch Level 1

                                      Hello pinkadmin,

                                       

                                      I do not have KB2982791 installed on the server I am testing on. I do have KB2970228 installed tho, and I am going to uninstall this aswell now and post my results later.

                                      • 16. Re: Unable to delete temporary files
                                        pinkadmin Level 1

                                        Good luck. I don't hold much hope for this, as we don't have KB2970228 installed on our system yet we do have the same issue. I'm going to propose uninstalling KB2993651 and KB2982791 to our change manager. Will keep you updated on the results.

                                        • 17. Re: Unable to delete temporary files
                                          StefanSch Level 1

                                          Ok, looks like uninstalling KB2970228 AND KB2993651 works for us (tested on one server)

                                          I will verify it on more servers as soon as possible.

                                           

                                          I have uninstalled/not installed the following Updates:

                                          KB2970228

                                          KB2993651

                                          KB2982791

                                          KB2975719

                                          KB2975331

                                           

                                          I DO have installed the following:

                                          KB2976897

                                          • 18. Re: Unable to delete temporary files
                                            Caorthann Level 1

                                            @pinkadmin : We did not have to uninstall KB2976897, only KB2993651.

                                            @StefanSch :  We do not have KB2970228 installed  (I'm pretty sure we either uninstalled or stopped roll out of MS14-045 when Microsoft recommended that customers uninstall around Aug 18 ( see Microsoft pulls MS14-045 and recommends uninstall if you have already deployed | Shavlik BlogShavlik Blog).  You are probably correct in that its a combination of the two that causes the issue,

                                            • 19. Re: Unable to delete temporary files
                                              digitlman77 Level 1

                                              Just upgraded one of my Citrix servers to Reader 11.0.9.  Still the same issue.

                                              • 20. Re: Unable to delete temporary files
                                                StefanSch Level 1

                                                After uninstalling KB2970228 and KB2993651 on all of our terminalservers, restarting and waiting a day I can now finally verify that this helped.

                                                @rhservices: Thank you for the hint

                                                @digitalman77: Have you checked for those two updates already?

                                                • 21. Re: Unable to delete temporary files
                                                  Hunv

                                                  Hi,

                                                   

                                                  we have the same issue in Windows 2008 R2 Terminalservers (without Citrix) and on Windows 7 Clients.

                                                  If you read the Description of the security Update KB2993651 (MS14-045: Description of the security update for kernel-mode drivers: August 27, 2014) you read the following:

                                                  Known issues of this security update

                                                   

                                                  So it seems, that is not a problem with Adobe Reader, but a problem with windows because even microsoft says, that it is an issue related to this patch.

                                                  This issue applies because the sticky temp-files are extracted fronts of the pdf-files. That is also the reason why some pdf generate this files and some not.

                                                   

                                                  Anyway: Maybe Adobe is able to do anything against this issue too.

                                                   

                                                  Regards,

                                                  Kristian

                                                  • 22. Re: Unable to delete temporary files
                                                    SuportTech01

                                                    Removing 2993651 fixed it on our Windows 2008 R2 XenApp 6.5 Farm.

                                                    • 23. Re: Unable to delete temporary files

                                                      download unlocker application , click on file and then delete

                                                      • 24. Re: Unable to delete temporary files
                                                        no1 knows

                                                        Hi all,

                                                         

                                                        for us the removal of KB 2993651 does not fixed the problem in out W2K8 R2 XenApp 65. farm. Still those "Z@R4C67.tmp files" within C:\Users\%USERNAME%\AppData\Local\Temp\3\acrord32_sbx\

                                                         

                                                        any more ideas?

                                                        • 25. Re: Unable to delete temporary files
                                                          StefanSch Level 1

                                                          Hello,

                                                           

                                                          please make sure you have none of these updates installed:

                                                          KB2970228

                                                          KB2993651

                                                          KB2982791

                                                          KB2975719

                                                          KB2975331

                                                          And if so, uninstall, reboot and check again if this helped.

                                                          • 26. Re: Unable to delete temporary files
                                                            George Kazantzis

                                                            Hi everyone. I currently have a Citrix Xenapp farm (provisioning services), on 6.5 2K8 R2 servers. I was also having these issues and only a reboot of the Xenapp server would clear these temps files. I was able to rename these files but could not delete them. This was causing Profile Manager to have entries all over my servers.

                                                            But the solution for me was doing the following 3 things and which cleared this issue :

                                                            1) Remove KB2970228

                                                            2) Remove KB2993651

                                                            3) Finally I removed adobe reader and reinstalled it from the adobe site (11.0.9).

                                                             

                                                            This setup has been live for 10 days without issues. I reapplied those patches on a test server and issues came back. Thus I will be avoiding both patches for a while until another comes up that resolves the issue. Hopefully this works for all of you.

                                                            • 27. Re: Unable to delete temporary files
                                                              mbiesheuvel

                                                              Hello everybody,

                                                               

                                                              We have had multiple customers with this problem. At almost all sites the solution was: remove KB2993651 (and KB2970228).

                                                               

                                                              Now we have 1 site where KB2970228 was not installed and KB2993651 was. Sites is MSFT 2008 R2 XenApp 6.5 Rollup 4 and Adobe Reader 11.0.0.9. I removed KB2993651 but the issue remains.

                                                               

                                                              I checked all KB's (KB2970228 KB2993651 KB2982791 KB2975719 KB2975331) but none are installed. This customers prints PDF a lot. Like more then 200 per day. Please provide a fix for it Adobe! The customer is already asking us if it's ok to use Foxit (which does not have this problem!)

                                                              • 28. Re: Unable to delete temporary files
                                                                Schoorties

                                                                Hello,

                                                                 

                                                                We have the same problem, 2 weeks Ago we solved it by removing KB2970228 and KB2993651 and it worked.

                                                                 

                                                                Then Microsoft published new updates and since the problem appears again.

                                                                 

                                                                We upgraded from Reader X to Reader XI but the problem still happens.

                                                                 

                                                                We are praying that Adobe will fix it very soon ! Unfortunately we can't use Foxit cause our company needs to fill some PDF from our state which can only be filled by Adobe Reader.

                                                                • 29. Re: Unable to delete temporary files
                                                                  Test Screen Name Most Valuable Participant

                                                                  It looks as if this is working exactly as Microsoft intended. Adobe Reader makes temporary fonts for good quality and fast printing, using methods Microsoft have recommended for over 15 years. Adobe Reader then cleans up the fonts, but Microsoft in their wisdom stop the fonts from being deleted until the session has finished (by which time Adobe Reader cannot, by definition, be running to delete them). It's hard to imagine what planet Microsoft were on when they decided this was a good solution to whatever the problem was. You can stop Adobe Reader from making fonts for printing by using "print as image" but you can see what this does to print time and quality.

                                                                  • 30. Re: Unable to delete temporary files
                                                                    jc2it

                                                                    We had this fixed until 10/16 when updates occurred on our systems. This is the list that was installed, and one or more caused the problem to reoccur. Any idea which of the 34 possibilities? I have started with OS updates, but have not had much luck with deducing the culprit. Also, on 10/15 Adobe Reader was updated to 10.1.4, but I don't think this was the cause, because our files started accumulating on the 16th.

                                                                     

                                                                    OS updates

                                                                    KB3000869 - MS14-060: Vulnerability in Windows OLE could allow for remote code execution

                                                                    KB3000061 - MS14-058: Vulnerabilities in kernel-mode driver could allow remote code execution

                                                                         This one modifies the Win32k.sys file. This file was also modified in the original culprit KB

                                                                    KB2987107 - MS14-056: Cumulative security update for Internet Explorer

                                                                        Perhaps this fix is causing the problem???   https://support.microsoft.com/kb/3004256

                                                                    KB2979570 - MS14-057: Description of the security update for the .NET Framework 3.5.1 for Windows 7 Service Pack 1 and Windows Server 2008 R2 Service Pack 1

                                                                    KB2977292 - Microsoft security advisory: Update for Microsoft EAP implementation that enables the use of TLS

                                                                    KB2972100 - MS14-057:

                                                                    KB2968294 - MS14-057:

                                                                     

                                                                    .NET updates:

                                                                    KB2979578v2

                                                                    KB2972107

                                                                     

                                                                    Office updates:

                                                                    KB2589352

                                                                    KB2825635

                                                                    KB2760598

                                                                    KB2687455

                                                                    KB2589298

                                                                    KB2878252

                                                                    KB2837606

                                                                    KB2597087

                                                                    KB2889836

                                                                    KB2883013

                                                                    KB2850016

                                                                    KB982726

                                                                    KB2880971

                                                                    KB2794737

                                                                    KB2837595

                                                                    KB2817369

                                                                    KB2687423

                                                                    KB2494150

                                                                    KB2760631

                                                                    KB2837581

                                                                    KB2878281

                                                                    KB2837579

                                                                    KB2687567

                                                                    KB2589375

                                                                    KB2810073

                                                                    KB2881071

                                                                    • 31. Re: Unable to delete temporary files
                                                                      jc2it Level 1

                                                                      KB3000061 - MS14-058: Vulnerabilities in kernel-mode driver could allow remote code execution

                                                                           This one modifies the Win32k.sys file. This file was also modified in the original culprit KB

                                                                       

                                                                      Based on the version of the Win32k.sys file I should have if I had installed KB2993651 I believe KB3000061 is what is causing the problem in October. I am going to test this, but it will be Monday 10-27-14 before I know for sure. If you can test sooner please let us know.

                                                                       

                                                                      Thanks,

                                                                      Job

                                                                       

                                                                      Schoorties, StefanSch, mbiesheuvel

                                                                      • 32. Re: Unable to delete temporary files
                                                                        giloup!

                                                                        Hi Guys!

                                                                        The solution provided by Adobe in 2011 is working.

                                                                         

                                                                        [WinFntSvr]

                                                                        TTToSysPrintDisabled=1

                                                                        T1ToTTDisabled=1

                                                                         

                                                                        Save this as acroct.ini copy it in the windows diorectory and bye bye the problem.

                                                                         

                                                                        We have a Xenapp 6.5 environnement on Windows 2008R2

                                                                        • 33. Re: Unable to delete temporary files
                                                                          Schoorties Level 1

                                                                          Hello again,

                                                                           

                                                                          I just tested and I confirm it works for us too on XenApp6.5 Win2008R2

                                                                           

                                                                          Do you have news about the print quality ? Adobe says that applying this may reduce the print quality.

                                                                           

                                                                          Regards

                                                                          • 34. Re: Unable to delete temporary files
                                                                            giloup! Level 1

                                                                            I didn't see any difference!

                                                                             

                                                                            I suppose it  must depend of the type of pdf file your printing


                                                                            • 35. Re: Unable to delete temporary files
                                                                              jc2it Level 1

                                                                              It is great that the Adobe problem can be fixed by changing settings. Removing the update also fixes some other problems we have seen.

                                                                               

                                                                              Removing KB3000061 fixes:

                                                                              • Problems with Z@*.tmp files being left in \\<RDPServer>\Users\<UserName> directory.
                                                                              • Print jobs getting stuck in the Amyuni print driver queue.
                                                                              • Also, it allows ProComm Plus to Copy to printer and send print jobs to a slave print via serial.
                                                                              • And perhaps a slew of other issues related to changing how the kernel handles Fonts.
                                                                              • 36. Re: Unable to delete temporary files
                                                                                12nico34

                                                                                None of the above helped for me.

                                                                                I was forced to install an other pdf viewer on the Remote Desktop server.

                                                                                I hope this issue will be fixed by Adobe or Microsoft.

                                                                                The other pdf viewers don't have the customization wizard.

                                                                                • 37. Re: Unable to delete temporary files
                                                                                  Learn2Code

                                                                                  The same issue experienced here on Windows 2008 R2 Standard running XenApp 6.5 With HRP04.

                                                                                  No post HRP04 Citrix hotfixes installed.

                                                                                  Adobe Reader XI version 11.0.1.

                                                                                  I can reproduce the issue every time by printing from a pdf and logging off.

                                                                                  We had all currently recommended microsoft windows hotfixes installed as of 17/10/2014.

                                                                                  I got it fixed by uninstalling the following updates (similar to what jc2it suggested):

                                                                                  KB2993651

                                                                                  KB2982791

                                                                                  KB3000061

                                                                                  (Hotfix 2970228 we don't have installed)

                                                                                  Until I uninstalled all 3 of those hotfixes the issue was not fixed and even reinstalling 2993651 later on causes this issue to come back.

                                                                                   

                                                                                  The key to resolving this seems to be removing whichever hotfix(s) bring down updated versions of: win32k.sys and gdi32.dll.

                                                                                  The versions of these files that the issue doesn't occur with for me is:

                                                                                  win32k.sys

                                                                                  Version: 6.1.7601.18512

                                                                                  Date: 18/06/2014 1:10pm

                                                                                   

                                                                                  gdi32.dll

                                                                                  Version: 6.1.7601.18275

                                                                                  Date: 3/10/2013 3:23pm

                                                                                   

                                                                                  Also I noticed much faster printing of PDF files from acrobat reader after removing these hotfixes, before removal the printing dialog box would stay on the screen for a while, now it's pretty much instant.

                                                                                  • 38. Re: Unable to delete temporary files
                                                                                    jc2it Level 1

                                                                                    It looks like KB3002885 will modify the win32k.sys on Win 2008 R2 server. I will try to test it later this week.

                                                                                     

                                                                                    http://support.microsoft.com/kb/3002885

                                                                                    • 39. Re: Unable to delete temporary files
                                                                                      WesleyL3

                                                                                      We have the same problem where user.domain.001 will be created on our Terminal Servers because of a Adobe Reader tmp file that is in use.

                                                                                       

                                                                                      Infra:

                                                                                           - Windows 2008R2 + SP1

                                                                                           - Remote Desktop Service Role

                                                                                           - Adobe Reader 11.0.0

                                                                                           - Roaming Profiles

                                                                                       

                                                                                      Removed these updates:

                                                                                           - KB2993651

                                                                                           - KB2982791

                                                                                           - KB3000061

                                                                                       

                                                                                      Still have the same problems unfortunately, do I miss anything?

                                                                                       

                                                                                      note: Will install 11.0.9 tonight on all Terminal Servers tonight.

                                                                                      1 2 3 4 Previous Next