11 Replies Latest reply on Apr 27, 2007 6:00 AM by lukaro

    Weird Publishing Bug in Contribute?

    Law808
      Hello to all Contribute experts and fanatics alike!

      For some reason I'm able to publish to my web server, but
      I'm unable to publish to my folders on my web server. Anyone
      know why?

      For example, I make a copy of a new page -- click Publish > Choose Folder> --
      I pick the specific folder I want to publish it to -- click Select (destination folder) --
      a screen pops up saying "Waiting for Server" -- Then it all freezes, and I have to shut it down.

      Anyone know why? Your reply is great appreciated. Thanks.
        • 1. Re: Weird Publishing Bug in Contribute?
          lukaro
          I wonder, could this be related to the permissions granted to the FTP account which you used in your connection settings to establish the Contribute connection?

          It certainly sounds like some sort of permissions issue. Look at whether the FTP account has write permissions to these folders, or maybe even move file permissions etc etc.

          I guess also the permissions that you can set to different users of Contribute might also be worth looking at.

          Rgds

          lukaro
          • 2. Re: Weird Publishing Bug in Contribute?
            Law808 Level 1
            Hey Lukaro,

            Are you referring to the Administer Websites option in Contribute?

            I have my Folder/File Access -- set to be able to Allow Users to edit files in any folder.

            Is that what you're referring to? If not, could you clarify what you mean?

            Thanks.
            • 3. Re: Weird Publishing Bug in Contribute?
              lukaro Level 1
              The first set of permissions I am referring to are those associated with an FTP account. For example, I use Serv-U FTP server, and when I wish to grant someone FTP access to my server, I set up a new user ac and grant priveleges to it such as read/write/create folder etc etc. So what I am saying is it is worth considering what privileges are assigned to whatever FTP account username and password you used to set up your Contribute connection, because if there aren't enough priveleges in the FTP account, it can block Contribute doing what it needs to do because it is using that given FTP ac to access the server.

              Secondly, Contribute has its own inbuilt set of permissions associated with users so I guess that is another avenue worth investigating but I don't know much about that.

              Rgds

              lukaro
              • 4. Re: Weird Publishing Bug in Contribute?
                e3hutrifrnjenlkend
                I'm having this problem whenever I try to Publish Drafts.... it says "Waiting for Server" and hangs then moves slowly while apparently publishing changes - then finally it pops up with an error message that the server is either down or not accepting connections.. which isnt the case because I'm connected fine before trying to publish and can reconnet with no apparent problems. Its only when I click "Publish" that this happens.....

                and get this....the kicker... it actually publishes some of the changes to the site ---with errors --- parts I didnt change or touch get messed up..... so everything is really messed up now and I need the draft to FULLY publish.... so it looks like the draft.........hellllp ... please :)
                • 5. Re: Weird Publishing Bug in Contribute?
                  wildgoosewebsites
                  One of my clients gets a similar error message, something like:

                  'You cannot publish this page because the server is down or is not accepting connections'

                  Like you, I know the server is fine, as I can connect. Please can anyone shed any light on what to do here?
                  • 6. Re: Weird Publishing Bug in Contribute?
                    lukaro Level 1
                    First, if you can, try establishing a Contribute connection from a different computer at a different location, then you'll know it's the individual computer setup that's the problem.

                    Then look at:

                    - Stability of user's internet connection. Is their internet connection cutting out?

                    - If the computer is on a network, see what network security is running and whether a firewall (or proxy server???) could be interfering.

                    Has this user been able to connect previously or have they never been able to connect?

                    Have you opened a ticket with Contribute support?

                    Rgds

                    lukaro
                    • 7. Weird Publishing Bug in Contribute?
                      wildgoosewebsites Level 1
                      Thanks, lukaro.

                      Identical Contribute connections elsewhere are fine. This particular user's internet connection is stable, but the user has never been able to connect. I tried to walk her through Advanced settings to turn on passive FTP etc, but she can't access those settings - Contribute says the reason is that she has 'unpublished drafts'. However, these drafts do not appear on the drafts console so she can't get rid of them either!

                      Driving me a bit crazy, this one.

                      Where is Contribute support help ticket facility? I didn't know there was such a thing.
                      • 9. Re: Weird Publishing Bug in Contribute?
                        lukaro Level 1
                        Note unpublished drafts can be deleted from the local computer by finding their location as per the above link about Draft File Locations.

                        Rgds

                        lukaro
                        • 10. Re: Weird Publishing Bug in Contribute?
                          wildgoosewebsites Level 1
                          Thanks, have opened a help ticket now.

                          Tried deleting drafts off my own machine (Mac) but couldn't find the exact location despite the above page.

                          User with problems is on Windows machine, so I guess she needs to check C:\Documents and Settings\username\Local Settings\Application Data\Adobe\Contribute 4

                          Should she delete everything in the _mm folder, or just the drafts?
                          • 11. Re: Weird Publishing Bug in Contribute?
                            lukaro Level 1
                            Only ever the individual draft files, nothing more.

                            For Contribute 4, drafts location is:

                            C:\Documents and Settings\username\Local Settings\Application Data\Adobe\Contribute 4\Sites\Site1\

                            where username is their Windows username and Site number may vary (depends on how many sites they have access to on their machine).

                            Ask them to tell you what files they can see in this folder (screenshot) before getting them to delete anything.

                            Rgds

                            lukaro