3 Replies Latest reply on Sep 5, 2014 7:47 PM by station_two

    Help I want Lr (on Mac OS X 10.6.8)

    barolone

      Hi, I want to get lightroom (preferably a trial version to start), I understood that Lr 5 is not supported by my Mac OS X 10.6.8. What do you suggest to do? Thanks! Max