5 Replies Latest reply on Apr 15, 2007 6:42 AM by MotionMaker

    replacing root movie

    Opera Rat Level 1
      Having given up on trying to load a movie clip into a target movie clip, I know have my buttons replace the root movie. It works great when I test it on my machine, BUT when I upload it - problems. The html page opens with the 1st movie running as it should. When I click on a button to replace this movie, down at the lower left part of the status bar it says "waiting for (website address)" and just sits there. What is going on? Why doesn't anything I do work in Flash anymore?

      I'm using this code on the instance of my button:

      on(release){
      loadMovie("largeWorks.swf",this);
      }
      and I've tried:

      on(release){
      loadMovie("largeWorks.swf",_root);
      }
      Is there something blocking a flash movie from getting another flash movie?
        • 1. Re: replacing root movie
          MotionMaker Level 1
          largeWorks.swf must be uploaded to same folder as the HTML document loading the container swf. Also be sure the spelling and capitalization are the same.

          • 2. Re: replacing root movie
            Opera Rat Level 1
            I do have them located in the proper place and named correctly. It all works when I test it on my computer from the HTLM page on my harddrive. What could the internet be doing that my computer is not?
            • 3. Re: replacing root movie
              MotionMaker Level 1
              "What could the internet be doing that my computer is not?"
              Here are some I can think of in the case of using the same HTML document for comparison:
              1. What I mentioned above?
              2. Security issues - cross domains. Do not see that here.
              3. Different folder paths inside the code which I do not see or inside the HTML document? Look for any drive paths in the HTML OBJECT and EMBED tags - look for *.swf in them?
              4. There is an external js file doing the loading that you did not upload or is not in the correct folder.
              5. Server does not return swfs. Again not the case since the main swf is being served.

              Keep in mind there is a difference between Control->Test Movie and HTML testing as well in that the Flash IDE is using one version of the Flash player but you could have a different version in the web browser. This is not your case as you stated you are testing it with HTML launch both local and from server.
              • 4. Re: replacing root movie
                Opera Rat Level 1
                Those damn capital letters. Sometimes you just don't see them for a week, especially if it works via the files on your harddrive in HTML, even though those files are capitalized and in the scripts in Flash they are not! Everything works great!

                Thanks for your help, Lon.
                • 5. Re: replacing root movie
                  MotionMaker Level 1
                  Super!