14 Replies Latest reply on Apr 11, 2007 4:10 PM by symmetricalMan

    External Actionscript File not being Included

    symmetricalMan Level 1
      Odd problem:

      Myself and a colleague are working on a project. We're both using Flash 8. We've both downloaded the latest Flash player.
      The project involves a series of perfume bottles, all lined up in a row. When you press a key on the keyboard, the associate bottle enlarges and some info on it appears. At the same time the other bottles fade out (an alpha change).

      The alpha change is driven using an external actionscript file, which is called (#include) at the top of the first line of script in the ‘main’ movie.

      The problem is, when I publish the swf file, the alpha change doesn’t work. When my colleague publishes it, it works. Why is this? It’s almost as if in publishing from my computer, the external .AS file is being ignored.

      I’ve tried calling the .AS file using a full path to the file. No change.

      I’ve tried uninstalling and reinstalling the Flash player, and older version of the player. No change.

      Here’s something else that’s odd: I’ve tried copying all the script from the external .AS file and embedding it into the main movie. No change. Is it that the publishing from my computer is corrupted? Other things I’ve published recently have worked fine?

      Any ideas?