3 Replies Latest reply on Sep 10, 2014 7:54 AM by Szalam

    raytracing 3d not visible in final rendering via AME

    fhoeg

      I used the 3D rendering function to create an extrusion of a vactor form. This all works fine except when I send this over to the Adobe Media Encoder its just ignoring the Raytracing and only rendering the outlines. Does anybody know how to fix this?

       

      Thanks a lot in advance!

        • 1. Re: raytracing 3d not visible in final rendering via AME
          fhoeg Level 1

          mhm it's actually working when I add the composition to the render list and not to the AME. There I can create a Quicktime file and the raytraced data appears.

           

          I forgot some technical background btw: I work on an iMac mid 2011 with a 3.1 GHz Core i5, 8GB of RAM and an AMD HD6970M with 1GB of memory. The system is mavericks 10.9.4 and I'm running the latest AE CC 2014.

           

          I think I'm gonna try the older CC version just to see if it's eventually a bug.

          • 2. Re: raytracing 3d not visible in final rendering via AME
            Rick Gerard Adobe Community Professional & MVP

            The Adobe Media Encoder will not use your GPU for rendering Ray-traced comps so rendering will take place only with the CPU, and this will be slow. It looks like your system does not have a compatible NVIDIA card so you will be using the CPU for all Ray-traced rendering anyway because you have no CUDA acceleration and should nave no CUDA drivers installed. If you did have a system with CUDA support then you would want to render a DI using a production codec with AE's Render Cue, then put that file in the AME to render your compressed file for delivery.

             

            That said, let's get to your problem. Try this after checking to make sure that you are checking your project using the Active Camera and noting the time in the comp your extruded layer is showing. Add your project to the Render Cue. In the Render Settings set the render time to about 30 frames that correspond to the comp time where you want to text rendering the extruded layer. In the output module choose Lossless, then export a test render.

             

            If the test renders properly then try using the AME to render the same bit of the composition as a test. If that does not work let us know and file a bug report. If your test from the Render Cue works and the AME doesn't then render a DI from the Render Cue of the entire comp and use the AME to compress it for delivery.

            • 3. Re: raytracing 3d not visible in final rendering via AME
              Szalam Adobe Community Professional & MVP

              Rick has some excellent info and suggestions. I don't have much to add to his troubleshooting steps.

               

              What I do have to add is a workflow suggestion: don't use the ray-traced renderer.

              Without the right NVIDIA GPU, it is going to render very slowly. There is a much more powerful way to work with 3d in AE and it's FREE with your CC subscription! Read all about it here: details of CINEMA 4D integration with After Effects On your machine it will render faster and you can do so much more with it! The ray-traced renderer is obsolete, so drop the old and busted and go with the new hotness.