0 Replies Latest reply on Sep 11, 2014 9:27 AM by RichardMcKenna

    Can't make HTTPS call to sub domain on ColdFusion 10 Standard

    RichardMcKenna Level 1

      Hi,

       

      I'd like to start by saying I didn't have this issue on CF9 Standard but recently updated to CF10 and now have the issue.

       

      I have a site and several sub domains running on IIS and CF10. They are all set up as separate sites but share a wildcard SSL certificate for *.domain.com

       

      www.domain.com

      forums.domain.com

      community.domain.com

      etc.

       

      I'm doing cfhttp calls between the sites. They work fine over http but over https, I get the all too common 'I/O Exception: peer not authenticated' error.

       

      Charset [empty string]

      ErrorDetail I/O Exception: peer not authenticated

      Filecontent Connection Failure

      Header  [empty string]

      Mimetype    Unable to determine MIME type of file.

      Responseheader    struct [empty]

      Statuscode  Connection Failure. Status code unavailable.

      Text    YES

       

      So I figured I needed to install the SSL certificate. I've installed the certificate in the correct key store and verified it's there using keytool -list and restarted. I even tried uninstalling and reinstalling it using the CertMan admin plugin but still get the error.

       

      I know there are other work arounds for this problem with Enterprise but as I'm running standard I can't use them.

       

      Does anyone have any suggestions? I'm pretty much stumped without https.

       

      Thanks,

       

      Richard