3 Replies Latest reply on Sep 15, 2014 1:48 PM by m_vargas

    AutoUpdateDisable=1 in mms.cfg not working on Windows 7 64bit

    RJThomas

      We are currently Deploying Adobe Flash ActiveX & Plugin 13.0.0.182 as part of a Image Deployment on Windows 7 Enterprise SP1 64bit. For some reason the installation completes and flash shows installed but the users are now getting prompted fo Update. We are also using SCUP and it is currently updating the 13.0.0.182 to 14.0.0.145. Our mms.cfg file exists in the C:\Windows\SysWOW64\Macromed\Flash folder.

      Can someone explain why the FlashUtil32...  exists in the C:\Windows\SysWOW64\Macromed\Flash folder, and the FlashUtil64...  exists in the   C:\Windows\Sysstem32\Macromed\Flash on Windows 7 64bit installs yet the  FlashUtil32...  exists in the C:\Windows\System32\Macromed\Flash on our Windows 7 Enterprise SP1 32bit systems?. Could this possibly lead to why the Users are being promoted to update  even though our mms.cfg file has worked for us for years?,. I have not been able to find a solution searching for similar issues although I have found one post where users using IE111 and possibly IE10 have seen similar behavior on older version 11x of the Flash players. In that thread it was reported that placing a second copy of the mms.cfg file in C:\Windows\Sysstem32\Macromed\Flash path was recommended, is this a viable fix?

      Flash 1.jpg

      Flash 2.jpg

      Flash 3.jpg

        • 1. Re: AutoUpdateDisable=1 in mms.cfg not working on Windows 7 64bit
          m_vargas Adobe Employee

          Hi RJThomas,

           

          On a 64-bit OS, the SysWOW64 directory is the location for 32-bit files and the System32 directory is the location for 64-bit files.  WOW64 = Windows on Windows64 (more info in this MSDN blog, As promised, what is the WOW64 and what does it mean to managed apps that you run on 64bit machines? - SpankyJ - Site Ho….  It can be confusing, but his is how Microsoft has decided to architect their OS.

           

          Flash Player expects the mms.cfg file to be in the 32-bit location, therefore, it is stored in the System32 directory on 64-bit OS, instead of the SysWOW64 directory.  However, we are aware of users getting update notifications even if they have AutoUpdateDisable=1 in the mms.cfg file.  We are working to resolve this bug, however, I don't have an estimate of when it will be fixed. The current work-around is to put the mms.cfg file in both the 32- and 64-bit locations.

           

          You also mention that your organization uses an image deployment of Windows 7 64-bit.  When Flash Player detects an update is available it creates a FlashPlayerUpdate RunOnce entry at HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce.  Please make sure the image you use does not have this entry created when you use it to image other machines. If so, regardless if the mms.cfg file has AutoUpdateDisable=1, the system is already configured to display an update notification.

           

          HTH.

           

          --

          Maria

          • 2. Re: AutoUpdateDisable=1 in mms.cfg not working on Windows 7 64bit
            RJThomas Level 1

            Thank You Maria,

             

               In looking at a freshly Imaged Windows 7 Enterprise SP1 64bit machine without Adobe Flash installed, when I ran the installer from the Adobe Website it does the Install exactly as the screen shots I included .....   Your Installer creates a mms.cfg in the C:\Windows\SysWOW64\Macromed\Flash folder, with the Following 2 entries....   SilentAutoUpdateEnable=0 & AutoUpdateDisable=1 ....

             

               It does not have a mms.cfg in the C:\Windows\System32\Macromed\Flash folder at all.

             

               For now we are dropping our mms.cfg in both locations just to be safe and ensure the users wont receive a prompt. BTW our SCCM 2012 R2 OSD task Sequence does a fresh install of the Adobe Flash Player ActiveX & Plugin for each Image Deployment, so since we are installing clean and then next step is to copy the mms.cfg file to its locations before opening flash will your statement on the reg key in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce still apply?

             

            Thank You for your Quick response on this ........ Richard

            • 3. Re: AutoUpdateDisable=1 in mms.cfg not working on Windows 7 64bit
              m_vargas Adobe Employee

              Hi Richard,

               

              On a 64-bit OS, Flash Player will only create the mms.cfg file in the SysWOW64 directory, so you won't see in the System32 directory.  The work-around for the issue your seeing, until we have a fix, is to deploy the file to the System32 directory in addition to the SysWOW64 directory, which you indicate you are now doing.

               

              Thanks for confirming your deployment process. Based on what you stated it does not appear the RunOnce key would be a factor since you're deploying the mms.cfg file immediately after installing Flash Player.  The chances of a user viewing Flash content and the entry being created are virtually zero in this situation.

               

              You can follow the status of this issue here, Bug#3673004 - Flash Player Prompts for Updates with 'Never Check for Updates' Enabled in Flash Player Settings Manager..

               

              --

              Maria