1 Reply Latest reply on Sep 21, 2014 7:30 AM by A.T. Romano

    Premiere Elements not logging to Photoshop.com?

    billatbirdisland

      Well. Adobe tech support tells me that my Adobe Premiere Elements 8.0 will not work with my Windows 7.  It used to but now I get error 400 and a statement that photoshop.com won't take my logon.  Do I have to upgrade?  It used to work just fine with Windows 7.

        • 1. Re: Premiere Elements not logging to Photoshop.com?
          A.T. Romano Level 7

          billatbirdisland

           

          Premiere Elements 8.0/8.0.1 will work on Windows 7 (assumed 64 bit).

           

          I am not sure why Adobe Tech support is telling you otherwise.

           

          For Premiere Elements 10 and earlier, there is no more Sign In and its relationship to photoshop.com and photoshop.com plus.

          The Sign In, photoshop.com, and photoshop.com plus are gone for Premiere Elements 10 and earlier. Adobe discontinued them. But, you can still use Premiere Elements 10 and earlier. Just do not try to Sign In. Ignore the Sign In and/or cancel out of any messages asking you to Sign In.

           

          In version 10 and earlier, you will probably still see thumbnails for photoshop.com plus members only content. However, that content is no longer available to you. That does not stop you from using the non photoshop.com content and the rest of the program.

           

          If your attempted use of Sign In is causing your problems, just do not attempt to Sign In under the circumstances. More information is needed to determine

          if you are overlooking the real cause of your problems which may not relate to Sign In. So, more details please.

           

          Usual Drill

          a. Working from 8.0.1 Update?

          b. Problem exists with or without the antivirus and firewall(s) disabled?

          c. Latest version of QuickTime installed on computer with Premiere Elements?

          d. Automatic Background Rendering (Premiere Elements workspace Edit Menu/Preferences/General) and AutoAnalzyer Options (Elements Organizer workspace Edit Menu/Preferences/AutoAnalzyer Options) disabled?

          e. Running program from User Account with Administrative Privileges?

           

          Please review and consider and then let us know the outcome.

           

          Thank you.

           

          ATR