3 Replies Latest reply on Sep 21, 2014 11:10 AM by Bob Somrak

    Lightroom for Mac 10.6.8

    mPhilipm

      I have an older Mac (10.6.8) not suitable for upgrade. Lightroom 4 is the latest compatible version. Does it make sense to get LR 4 now? WIll I be able to upgrade (to LR 5 or 6) when I get a new computer?