3 Replies Latest reply on Apr 14, 2007 9:20 AM by Newsgroup_User

    Text Member Director bug?

    Level 7
      Hi there,

      Whilst trying to track down what I though was my own bug, I discovered that
      with Director 8.5's text member charPosToLoc() function I seem to have found
      a strange anomaly....

      1. Create a text member. Set framing to Adjust To Fit and wordWrap to on.
      2. Starting with an empty member type text into it until the first line, is
      almost filled.
      3. Type a row of empty space chars (not they do not force the text member to
      return to the second line).
      4. Put the member.charPosToLoc(member.char.count).
      5. You will observe that the resulting loc.locH is way beyond the right hand
      edge of the text member's width!

      Can anyone replicate, or suggest a work around? It's a real problem for one
      aspect of my Chatroom project.

      Thanks experts!

      Richard Smith


        • 1. Re: Text Member Director bug?
          Level 7
          I've got an ugly work around working involving inserting a RETURN char where
          ever the spaces bleed beyond the member.width.

          Still be interested if anyone has an elegant work around though :)

          Thanks!

          Richard


          • 2. Re: Text Member Director bug?
            Chunick Level 3
            I'm also working on a chat, but using mx2004... and it still occurs in mx2004 as well. Seems to be a bug that has carried over to the newest version. Can I ask the context to which you're needing to set the text member to adjust to fit with wordwrap?... it seems like you are trying to set up chat bubbles or something.
            • 3. Re: Text Member Director bug?
              Level 7

              "Chunick" <webforumsuser@macromedia.com> wrote in message
              news:evqp6l$nq4$1@forums.macromedia.com...
              > I'm also working on a chat, but using mx2004... and it still occurs in
              > mx2004
              > as well. Seems to be a bug that has carried over to the newest version.
              > Can I
              > ask the context to which you're needing to set the text member to adjust
              > to fit
              > with wordwrap?... it seems like you are trying to set up chat bubbles or
              > something.

              Yes, you are quite right, very observant! :)

              I had a bug with my smiley placement within the bubbles, but that work
              around fixed it. Ain't smiley placement a pain ? ;)

              Cheers, and good luck with your chatroom!

              Richard