5 Replies Latest reply on Sep 23, 2014 11:43 AM by valcoholic

    content doesn't show up in final rendering

    valcoholic

      Hello there,

      I got a strange problem. I'm working on a template for an App-promotion-video-clip that contains a 3D phone spinning and moving around with a composition on it's frontside showing the App in action.

      I have a few compositions available to render that clip for 480p, 720p and 1080p. Basically the 720p and 480p just take the 1080p-clip and scale it down.

      So, as long as I'm in editmode, everything looks fine. When I'm previewing my stuff via RAM Preview, it renders perfectly fine. But as soon as I want to render the movie, the content on the phone's screen doesn't show up.

      It used to work when I started working on that template, so at some point I must have done something wrong.

      Maybe you guys have some ideas, obviously my main question remains, what could cause content to be renedered in the editor window but not in the final result?

       

      thanks for your time,

      cheers

      val

        • 1. Re: content doesn't show up in final rendering
          Todd_Kopriva Level 8

          Show screenshots of your Timeline panel, render settings, and output module settings.

           

          Also, give the exact version number of After Effects and your operating system.

           

          In general, it helps if you provide answers to the questions listed here: "FAQ: What information should I provide when asking a question on this forum?"

          • 2. Re: content doesn't show up in final rendering
            Rick Gerard Adobe Community Professional & MVP

            The most obvious question is are you using the active camera view to do your previews? If the answer to that is yes, then scaling down your is likely causing a shift in the position of the contents of the phone so that it is behind the phone instead of in front of it. This can happen easily when you scale 3-D layers, especially if you have moved the anchor point.

             

            My workflow would have been too render the original HD composition as a digital intermediate or DI using a lossless format and then use the Adobe media encoder her to make the other smaller versions and the full-size copy for distribution.

            • 3. Re: content doesn't show up in final rendering
              valcoholic Level 1

              @Rick Gerard: thanks for your quick answer, I agree that I'd just render the 1080p version and then make the web-versions via Media Encoder. I'd actually do that just because I like the Encoder for its speed. I've provided a bit more information about that project below, so maybe it's a bit clearer now.

               

              @Todd_Kopriva: Ah yeah, sorry for that. I'm running After Effects 2014 CC on Mac OS 10.9 (Mavericks).

              I've provided the screenshots here:
              editor: http://adobe.ly/1C5xe33

              timeline: http://adobe.ly/1uZYEnN

              output: http://adobe.ly/1poF3YF

              resulting .mov file: http://adobe.ly/1simCg0

               

              it's the german version, but I hope it's somehow clear where everything goes. I actually haven't really changed any output settings, but no matter if I'll just render that kind of raw .mov data or if I directly send the footage over to Media Encoder, the result stays the same.

              And, maybe it's obvious, but I'm not perfectly experienced with working in AE. I'm using it for years now, but not full time, more like 2-3 times a year for animation projects, so there are some things I'm not too comfortable with yet. Like I haven't worked too much with 3D objects, so it's likely I ruined it somehow. Still I'm wondering how that content on my phone's face could disappear after it gets rendered in the RAM Preview.

               

              thank you guys for your time!

              • 4. Re: content doesn't show up in final rendering
                Szalam Adobe Community Professional & MVP

                You didn't tick the box to make it a guide layer by accident, did you?

                • 5. Re: content doesn't show up in final rendering
                  valcoholic Level 1

                  Thanks Szalam, but nope, I didn't.
                  I actually finished the project by doing a little workaround. I just took the comp that was missing, placed it where I wanted it to be and linked it to the 3D layer. Of course it worked fine, but the problem didn't got solved as I don't understand how that comp couldn't show up before.

                  [edit] OK, now I checked out my workfile again and just moved the Layer with the onscreen-content around, rendered the movie out and suddenly it worked.

                  Still I got no clue what I did wrong in first place, but somehow there's sitting a little goblin inside AE that doesn't want me to find it out. Now I can't even recreating the situation where it wouldn't work anymore. Or yeah, I could open a backup and .... nah I guess I'm happy everything works fine now.