1 Reply Latest reply on Jun 27, 2007 10:58 AM by Sataracs

    Strange font embed error only on my comp.

    NewFlex
      I embeded a font into my css file. However, the main.mxml page is showing several errors.
      1084:Syntax error: expecting rightparen before s.
      1093: Syntax error.
      1094:A string literal must be terminated before the line break

      I sent to code to my cousin and he got it to work on his 2.01 builder without any modifications to the code i sent.
      I emailed to code to my house and tried it on my house computer with builder 2.01 and still had no problems.
      The issue seems to be with my office computer. How can this be happening.
      I un-installed, re-installed, got the latest java etc...

      To further diagnose the problem, i copied the inline embed font code from adobe quick example. Same error.

      I used this code directly from the adobe site.

      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application
      xmlns:mx=" http://www.adobe.com/2006/mxml"
      layout="horizontal"
      horizontalAlign="center"
      verticalAlign="center"
      viewSourceURL="src/EmbeddingFonts/index.html"

      >

      <mx:Style>
      @font-face
      {
      font-family: Copacetix;

      src: url("assets/copacetix.ttf");
      unicode-range:
      U+0020-U+0040, /* Punctuation, Numbers */

      U+0041-U+005A, /* Upper-Case A-Z */
      U+005B-U+0060, /* Punctuation and Symbols */
      U+0061-U+007A, /* Lower-Case a-z */
      U+007B-U+007E; /* Punctuation and Symbols */

      }

      .MyTextStyle
      {
      font-family: Copacetix;
      font-size: 24pt;
      }

      </mx:Style>

      <mx:Text styleName="MyTextStyle" text="Embedded fonts rock!" width="100%"/>


      </mx:Application>

      -----------------------------------------------------



      What could it be on my computer that is causing this. Any help would be greatly appreciated.
        • 1. Re: Strange font embed error only on my comp.
          Sataracs
          I am getting the exact same error. I just switched from a PC to a mac, copied over the files, and now I get this compiler error when I try to embed a font.

          Code:
          @font-face
          {
          src:url("Frutiger-Roman.ttf");
          fontFamily: myFrutiger;
          flashType: true;

          }

          Error:
          Severity and Description Path Resource Location Creation Time Id
          Syntax error: expecting rightbracket before private. [Generated code (use -keep to save): Path: main-generated.as, Line: 3162, Column: 2] LogoMaker2SVN-ReCompile Unknown 1182967045208 1832
          1093: Syntax error. LogoMaker2SVN-ReCompile main.mxml line 3 1182967045204 1831
          1084: Syntax error: expecting rightparen before s. LogoMaker2SVN-ReCompile main.mxml line 3 1182967045202 1830

          I really, really need this to be fixed, if you have had this before, please post!