3 Replies Latest reply on Nov 3, 2014 9:47 AM by Ben, Typekit Support

    [CC][AS] Typekit messagebox nightmare

    JohnDevlon Level 1

      Hi,

       

      I've created an automated Applescript workflow using Indesign CS 5.5  and everything worked fine. Migrating the workflow to Indesign CC, became a real nightmare.

      From time to time the missing font Typekit message dialog box appears and I'm not able to supress the warning permanently, setting the user interaction level to never interact would not disable this feature permanently.

       

      How do I permanently kill/remove/trash/delete the TypeKit framework ? Can it be disabled? Is it a plugin in Indesign and can it be removed? Or can I remove the framework from the application package sub-folder?

      How do I stop this messagebox from appearing ...

       

      This feature is a real pain the ... head ....

       

      Kind regards

        • 1. Re: [CC][AS] Typekit messagebox nightmare
          Ben, Typekit Support Adobe Employee

          Hi John,


          I'm sorry that you ran into trouble with this. Some users have reported an issue in the current version of InDesign which can temporarily deactivate installed fonts. Please note that this is actually unrelated to Typekit; it just happens to occur at the time you see our logo in the missing fonts window. If you'd like, you can turn off Typekit in the Creative Cloud app under Gear > Preferences > Fonts > Off. However, this won't disable the missing fonts dialog which I believe is the issue here.

           

          The InDesign team is still investigating the factors which trigger this situation, but the basic issue is this: the Missing Fonts dialog causes fonts which are managed through Extensis Suitcase and FontExplorer to not auto-activate correctly, or for managed fonts to even be visible in the application after upgrade.

           

          In both cases, the InDesign Missing Fonts dialog appears to override the Font Management tool dialogs that allow users to manage fonts within the Application.

           

          If you use Suitcase Fusion, there is a simple configuration change needed:

          1. close the Missing Fonts window

          3. go to the Type menu and select "Suitcase Fusion 5".

          3. From the submenu, choose "Library" and then check "All Libraries" so all fonts can be auto-activated as needed

          4. from the Type menu, select "Suitcase Fusion 5" again, and then "Check Document’s Fonts" to activate the missing fonts,

           

          If the font is being managed by Suitcase, it will find and update the fonts.

           

          In FontExplorer, if your managed fonts are not visible in InDesign after upgrading to InDesign 9.2

           

          Go to FontExplorer/Tools and select

          1. Clean System Font Caches (this will require a system reboot)

          2. Clean Application Font Caches

           

          On non-Mavericks systems, you will need to de-activate and then reactivate font protection.  Launch a terminal window and enter

           

          sudo atsutil fontprotection -off

          Then enter

          sudo atsutil fontprotection -on


          Relaunch InDesign. your managed fonts should now be visible and auto-activation should work.

           

          The fonts can always be activated from within the Font Management software itself, even with the missing fonts dialog open.

           

          The InDesign team is looking into the issue to determine the root cause as well; our apologies for any inconvenience it causes in the meantime.


          Cheers,

          Benjamin

          • 2. Re: [CC][AS] Typekit messagebox nightmare
            liodub

            This is just plain to complicated. I've lost 4 hours trying to open a file and retrieving fonts, still not working. I want to deactivate Typekit. How do I do that?

            • 3. Re: [CC][AS] Typekit messagebox nightmare
              Ben, Typekit Support Adobe Employee
              HiLionel,

               

              You can turn off Typekit in the Creative Cloud app under Gear (upper right corner) > Preferences > Fonts > Off.

               

              However, this might not solve the issue you're seeing if it's being caused by what I mentioned above. If you need further help, you can shoot us an email at: support@typekit.com

               

              Cheers,

              Benjamin