6 Replies Latest reply on Sep 26, 2014 9:22 AM by al barcheski

    rendering to create an interlaced file from AE

    al barcheski


      in After Effects 10.0.2.4


      AE timeline > Composition Settings > Frame Rate: 29.97

      in the render Queue,

      Render Settings > Field Render > "Upper Field First"

      but the file comes out

      Progressive.

      .mov, mp4, m2v ... all progressive.

      our Chyron Mosaic Clip player says "this file from AE is progressive. i won't play it. i want interlaced."

       

      also, a MediaInfo says "yep, it's progressive."


      what is needed to be done to render this so the final file is interlaced?


      thanks in advance for any help you can give

      al b


        • 1. Re: rendering to create an interlaced file from AE
          Mylenium Most Valuable Participant

          Well, have you actually opened up the encoder sub-panels and set the field dominance there? Doesn't sound like it.

           

          Mylenium

          • 2. Re: rendering to create an interlaced file from AE
            al barcheski Level 1

            example:

             

            Render Queue > Output Module > Format  > Quicktime > Format Options > MPEG-4 Video > Basic Settings > Quality=100

             

            Render Queue > Render Settings > Field Render > "Upper Field First"

             

            where else is there to select field dominance/interlace/progressive?

             

            there is a setting somewhere, however, it eludes me.

             

            thanks for your help & ideas

            al b

            • 3. Re: rendering to create an interlaced file from AE
              Rick Gerard Adobe Community Professional & MVP

              Open the codec options. I would use the Adobe Media Encode. You will get better results.

              • 4. Re: rendering to create an interlaced file from AE
                al barcheski Level 1

                unfortunately, even using media encoder:

                 

                Export Settings > Video Tab > Video Codec > [Codec Settings] button is grayed out & therefore won't open

                Export Settings > Video Tab > Field Type > Upper First

                 

                that rendered file is

                 

                Progressive

                MediaEncoder.png

                 

                thanks for your help and ideas

                al b

                • 5. Re: rendering to create an interlaced file from AE
                  Rick Gerard Adobe Community Professional & MVP

                  Here's the deal. If you have progressive footage at any frame rate and you separate fields then you have two identical fields. In AE you don't have holes in the scan lines like you do with NTSC footage because the holes are filled in by interpolation so the combing effect is minimized, and if you separate fields the empty spaces are filled in by interpretation. There is no description of the footage you used in your project in this thread so I can only assume that your project contains only progressive original footage and that the other elements in the project are not moving. Here's why:

                   

                  If you put progressive footage into the Render Cue or the AME and you select separate fields, the time difference between fields does not exist so when the footage rendered as interlaced so you will end up with pairs of identical fields. There's no way around that without doing some fancy time manipulation in the composition timeline. (Twixtor, Time Remapping, Frame Blending). If you want to have double the time slices, like you get with interlaced footage, then you have to use some temporal processing to create those in-between slices of time.

                   

                  I just checked this out with CC using both the render cue and the AME. There is absolutely no way that I can take a project that has moving elements and not end up with interlaced footage where each field is a different moment in time. There is also no way to create unique fields from progressive original footage without some kind of temporal processing in the timeline of an AE comp.

                   

                  Here's how to check for interlacing:

                  1. Import your file into AE
                  2. Check file interpretation by selecting the footage in the Project Panel and then go to File>Interpret Footage>Main
                  3. Turn on Separate fields
                  4. With the footage still selected go to File>New Comp from Selection
                  5. Go to the Composition settings, select the frame rate, use the right arrow key to move to the end and type in *2 to double the frame rate of the composition
                  6. Step through the project one frame at a time using the Page Down key or Cmnd/Ctrl + right arrow key and check for motion in the frame
                  7. Go back to file interpretation and reverse the field order
                  8. Repeat step 6

                  If the motion is all in one direction in step 6 but goes back and forth in step 8 (or vice versa) then your footage is interlaced and the problem is with the metadata in the footage. If the footage shows two identical frames at a time then even if it is interlaced, it will appear as if it is progressive because you have identical pairs of fields.

                   

                  If you still can't make this work then take a clip that will work in your Chyron Mosaic Clip player and analyze it. See where you can find differences. Recompress the clip using the AME or the Render Cue and see if that works.

                  • 6. Re: rendering to create an interlaced file from AE
                    al barcheski Level 1

                    thanks for taking the time to spell it out like that.

                     

                    i'll grab my lab coat and fire up the Bunsen burner do some testing.

                     

                    side note...

                     

                    a "MediaInfo" sniff of a file that the clip player does like does not list the file as Interlaced nor Progressive.  it just doesn't say either way. 

                     

                    so perhaps in chyron land, ignorance is bliss.

                     

                    thanks again for all your help

                    al b