19 Replies Latest reply on Sep 29, 2014 5:52 AM by Anit_Kumar

    cf11 install doesn't create cfide in web root

    ChrisGaelic

      I've been running cf8 on a windows webserver 2008 with IIS7.5 and have just installed cf11. The install completed successfully to the point of opening cfadmin and then failed. On looking in the web root directory as set in IIS, the old CFIDE folder had not been updated, so cf11 was attempting to use the cf8 version.

       

      I renamed the old cfide folder to cfide08, uninstalled cf11 and tried reinstalling it again - but still no cfide folder was created for cf11, and I couldn't open cfadmin. The cfide folder does get created in c:\ColdFusion11\cfusion\wwwroot\cfide

       

      Has anyone else experienced this, or know how to fix it?

        • 1. Re: cf11 install doesn't create cfide in web root
          BKBK Adobe Community Professional & MVP

          Shouldn't it be at c:\inetpub\wwwroot\CFIDE instead? In fact, shouldn't your site be in c:\inetpub\wwwroot\?

          • 2. Re: cf11 install doesn't create cfide in web root
            Carl Von Stetten Adobe Community Professional & MVP

            I don't believe the ColdFusion installer will touch C:\inetpub\wwwroot by default, or any other location outside of the ColdFusion installation directory.  Someone must have copied the CF8 CFIDE folder into C:\inetpub\wwwroot (probably as a security measure).  What should happen is that when you run the Web Server Configuration Tool to connect ColdFusion to IIS, it should create a virtual directory called "CFIDE" in some or all of your IIS web sites, and that virtual directory will point to C:\ColdFusion11\cfusion\wwwroot\cfide.

             

            When you install ColdFusion 11, don't connect it to IIS initially (during the installation there is a screen where you have the option of connecting to a web server or just using the built-in web server - use the built-in one initially).  Once you have verified ColdFusion has installed correctly and you can get into the CF Administrator, install Update 1 (this has some fixes for the IIS web connector).  Go into IIS and make sure all of the CF8 handlers are removed and all virtual directories are removed from web sites.  Then run the Web Server Configuration Tool to connect CF to IIS.  That should create the "jakarta" and "CFIDE" virtual directories either on all web sites or the specific site you choose.

             

            -Carl V.

            • 3. Re: cf11 install doesn't create cfide in web root
              ChrisGaelic Level 1

              Hi Carl,

               

              Thanks for that. I've now uninstalled cf11 and reinstalled it to use the built-in webserver, and was then able to run the configuration tool and then open cf11 admin.

               

              However, that's as far as I could go. cf11 admin doesn't include Update 1 for download - only cf10 updates. When I checked whether the config tool had copied across all my datasources, custom tags and components, there was nothing.

               

              Do you know if Adobe have made Update 1 available yet? - I see some forum discussion on this, and it appears to be available - but not from my cf11 admin.

               

              I'm getting really nervous about this as I'm running a production webserver with around 100 websites, including ecommerce and call management applications. I can't afford for anything to go wrong, and what I'm seeing at the moment looks pretty flaky.

               

              Cheers,

              Chris

              • 4. Re: cf11 install doesn't create cfide in web root
                ChrisGaelic Level 1

                I spoke to soon. Installing cf11 to use the built-in webserver has now broken all of my cf8 applications.Uninstalling cf11 doesn't help. This brings into sharp focus why I stayed with cf8 for so long after cfmx nearly broke my business...

                • 5. Re: cf11 install doesn't create cfide in web root
                  ChrisGaelic Level 1

                  Ok, I deleted and re-established the iis connections using the web server config tool, and restarted my server, and the cf8 apps are working again. Boy, I hate upgrading coldfusion!

                  • 6. Re: cf11 install doesn't create cfide in web root
                    BKBK Adobe Community Professional & MVP

                    Sorry to hear about your installation headaches. Coldfusion 8 and Coldfusion 11 share some settings, the most obvious example being port 8500. You should have disabled Coldfusion 8 before installing Coldfusion 11. If you wish to run both versions concurrently, then you should install them on separate servers.

                    • 7. Re: cf11 install doesn't create cfide in web root
                      ChrisGaelic Level 1

                      I really want to just upgrade cf8 to cf11, and for my datasources, webservices, custom tags, components and iis settings to all come across in the process. I would then un-install cf8 and work through any functional differences between the two releases.

                       

                      If the upgrade fails then I need to be able to back out and return to using cf8 - which so far has been possible.

                       

                      What I want to avoid, for obvious reasons, is for the cf11 upgrade to fail, and for my cf8 installation to be corrupted and require a complete reinstall. Given the trouble I've had so far, I am seriously considering doing a clean install of cf11 on another server, and then porting all my applications across - but not a trivial task, and expensive.

                      • 8. Re: cf11 install doesn't create cfide in web root
                        BKBK Adobe Community Professional & MVP

                        ChrisGaelic wrote:

                         

                        Given the trouble I've had so far, I am seriously considering doing a clean install of cf11 on another server, and then porting all my applications across - but not a trivial task, and expensive.

                        That has always been my preference. Nevertheless, if you choose to upgrade CF8 to CF11, I will advise you to seek the guidance of Adobe Staff or of someone who has had experience in the exact same upgrade process.

                         

                        Upgrading across 3 major software versions is bound to have risks, some potentially big. It all depends on how you go about it. In any case, plan and document the upgrade process. Identify the risks and the safeguards that enable you to fall back to the original state. In short, mitigate the risks as you would in any process where you have to replace an old, but well-functioning, piece of technology with a much newer version.

                        • 9. Re: cf11 install doesn't create cfide in web root
                          Anit_Kumar Adobe Employee

                          Hi Chris,

                           

                          ColdFusion 11 will not allow you to migrate your settings from ColdFusion 8. CF allows you to migrate your settings automatically, only from two versions back. That is the reason, it didn't import the settings at your end.

                           

                          If you are using Enterprise version, then I will suggest you to create a CAR package and import your settings.

                           

                          Regards,

                          Anit Kumar

                          • 10. Re: cf11 install doesn't create cfide in web root
                            ChrisGaelic Level 1

                            Hi Anit,

                             

                            Thanks - at least I know what I'm dealing with. I've only downloaded the trial version, and will purchase the cf11 standard when it is all installed and running properly.

                             

                            Is it possible for me to download a trial version of cf10, do the upgrade from cf8, and then upgrade from cf10 to cf11?

                             

                            Cheers,

                            Chris

                            • 11. Re: cf11 install doesn't create cfide in web root
                              Anit_Kumar Adobe Employee

                              ColdFusion 10 is not available to download anymore. It doesn't seem, that you may have it under your account, as you never purchased one. As I said, If have Enterprise version of CF8, then you can create a CAR package and import your settings to CF10/11.

                               

                              Regards,

                              Anit Kumar

                              • 12. Re: cf11 install doesn't create cfide in web root
                                ChrisGaelic Level 1

                                Hi Anit,

                                 

                                I don't have the enterprise version of cf8, so creating a CAR package is not an option. However, I do have a download of cf9.1 which I never installed. Presumably I could install this over cf8 as a trial, and then do the upgrade to cf11.

                                 

                                Adobe's attitude to earlier versions is a concern for me. Looking through this, and other forums, cf11 isn't free of problems. cf10 has at least had the benefit of being a mature release. If I had problems with cf11, I'd want to be able to drop back to cf10 until such problems are resolved.

                                 

                                Cheers,

                                Chris

                                • 13. Re: cf11 install doesn't create cfide in web root
                                  Anit_Kumar Adobe Employee

                                  Hi Chris,

                                   

                                  ColdFusion 11 is very much stable after update 1. You were having problems migrating to CF11, because the migration was not supported. Regarding your setting migrations, here are some steps you can follow.

                                   

                                  Install ColdFusion 9, but don't create the connector to your website during the install. Use the built-in connector instead. After the installation, you will get the prompt to migrate the settings (after admin login). Choose "yes" to migrate. In case, for some reasons, migration wizard didn't appear, then try the following:-

                                   

                                  1. Start ColdFusion 8 and 9 both.
                                  2. Once both the CF servers are running then try the following steps:-

                                   

                                  1. Navigate to adminconfig.xml at \ColdFusion9\lib\ and open it with text editor (say notepad).
                                  2. Change the value from “false” to “true” in

                                       <runsetupwizard>false</runsetupwizard>

                                       <runmigrationwizard>false</runmigrationwizard>

                                       <runmxmigrationwizard>false</runmxmigrationwizard>

                                       and in     <migratecf8>false</migratecf8>.

                                     3.   Save the file and restart ColdFusion 9 Service.

                                     4.   After restarting the service, you will get the migration wizard. Follow the onscreen wizard to continue.

                                   

                                  Hope this helps.

                                   

                                  Regards,

                                  Anit Kumar

                                  • 14. Re: cf11 install doesn't create cfide in web root
                                    ChrisGaelic Level 1

                                    Hi Anit,

                                     

                                    Thanks for that - I appreciate you taking the time to help.

                                     

                                    Since I'd be doing that on my production server, I want to minimize any risk. I have assumed to date that I should leave cf8 running while I do the upgrade - is this correct?

                                     

                                    Presumably, if the cf8 to cf9 migration all works, then I should repeat the process for cf9 to cf11.

                                     

                                    Cheers,

                                    Chris

                                    • 15. Re: cf11 install doesn't create cfide in web root
                                      Anit_Kumar Adobe Employee

                                      Yes, you have to leave both the servers running and that's what I mentioned in the instructions as well.

                                      1. Start ColdFusion 8 and 9 both.
                                      2. Once both the CF servers are running then try the following steps:-

                                       

                                      Once the migration is completed, follow the same instructions for migrating from ColdFusion 9 to ColdFusion 11. After you verify the settings being migrated successfully, then you can uninstall ColdFusion 9.

                                       

                                      Regards,

                                      Anit Kumar

                                      • 16. Re: cf11 install doesn't create cfide in web root
                                        ChrisGaelic Level 1

                                        Thanks Anit,

                                         

                                        I'll try it tonight and let you know how I get on. If this works, then it will be relevant for anyone else with the same problem.

                                         

                                        Cheers,

                                        Chris

                                        • 17. Re: cf11 install doesn't create cfide in web root
                                          ChrisGaelic Level 1

                                          Wipe out!!  - the copy of cf9.01 64bit that I downloaded from Charlie Arehart's blog (Getting #ColdFusion 8/9 downloads (with Verity): ways that may work even after today - Charlie Arehart's Blog) gave me a Unsupported Version error and stopped.

                                           

                                          So, I'm back to where I started.

                                           

                                          After taking some time to cool down, I have to say this: I've been using ColdFusion since v1.5, upgrading as each new release became available. When CFMX came out, the bugs and functional changes resulted in nearly closing down my web developement business. CF8 finally got me out of that and I've been reluctant to go through more pain ever since. However, with cf11 coming out, there is no longer support for cf8, and anyway, some of the new functionality in cf10 and cf11 is becoming necessary for future development.

                                           

                                          So now Adobe have cut me adrift, with no migration path from cf8 to cf11. I can't even buy cf10 as a transition. For what reason??? Yes, I can do a full install on a new server, manually recreating my entire environment of websites, datasources, webservices, virtual directories, and custom tags and components. The  cost to me of doing that is more than the full cost of the new standalone standard server license.

                                           

                                          This is a gripe at Adobe - not Anit, Carl, and BKBK, who've taken time out to help me. I'm not a happy Adobe customer and I hope that someone from that organisation might get to read this.

                                          • 18. Re: cf11 install doesn't create cfide in web root
                                            ChrisGaelic Level 1

                                            Ok, I found another link, this time to download cf9 from within the trials.Adobe.com site. This install worked up to the point where I got to make the changes to the adminconfig.xml file and then to rerun the migration wizard.

                                             

                                            This time I got an error and the migration.log file effectively said that it couldn't find the C:\ColdFusion9\temp_zip\cfusion-examples-db.zip file, and that the C:\ColdFusion9/lib/cf8settings folder was missing. I checked, they were indeed not present.

                                             

                                            About the only good thing I can say about this is that my cf8 applications are not broken.

                                            • 19. Re: cf11 install doesn't create cfide in web root
                                              Anit_Kumar Adobe Employee

                                              Can you check your pm?

                                               

                                              Regards,

                                              Anit Kumar