3 Replies Latest reply on Apr 5, 2007 6:00 AM by SilentBob'secretfusion

    cfgrid format="xml"

    SilentBob'secretfusion Level 1

      I cannot get this to work. Any ideas?

      <cfquery name="obtain" datasource="esp">
      SELECT #form.querystructure#
      FROM tbl_pav2


      <cfgrid format="xml" query="obtain" name="obtain" width="100%" height="700" >


        • 1. Re: cfgrid format=&quot;xml&quot;
          SilentBob'secretfusion Level 1
          This is what the above code is returning. The query definitely has data in it, when I try format="flash", it works fine.


          <script type="text/javascript" src="/CFIDE/scripts/cfform.js"></script>
          <script type="text/javascript" src="/CFIDE/scripts/masks.js"></script>
          <script type="text/javascript">
          function _CF_checkCFForm_1(_CF_this)
          //reset on submit
          _CF_error_exists = false;
          _CF_error_messages = new Array();
          _CF_error_fields = new Object();
          _CF_FirstErrorField = null;

          //display error messages and return success
          if( _CF_error_exists )
          if( _CF_error_messages.length > 0 )
          // show alert() message
          // set focus to first form error, if the field supports js focus().
          if( _CF_this[_CF_FirstErrorField].type == "text" )
          { _CF_this[_CF_FirstErrorField].focus(); }

          return false;
          }else {
          return true;

          <form name="CFForm_1" action="/reports/rpt_PAV_select_p2.cfm" method="post" onsubmit="return _CF_checkCFForm_1(this)">

          <div><input type="hidden" name="__CFGRID__CFForm_1__obtain" value="" /></div>
          • 2. Re: cfgrid format=&quot;xml&quot;
            insuractive Level 3
            What version of CF are you using? I can't find a reference to <cfgrid format="xml"> in the 6.1 documentation on my machine, but its present in the CFMX 7 documentation.
            • 3. Re: cfgrid format=&quot;xml&quot;
              SilentBob'secretfusion Level 1
              Running 7 with the lastest update. I googled this and can find nothing about this format for this tag. Apparently, it doesn't work.