19 Replies Latest reply on Nov 28, 2014 12:39 PM by JPomonik

    Edge Animate large project video import bug

    JPomonik

      I'm working on a large project in Edge Animate that will (hopefully) become a full website with lots of video assets.  The videos are various samples of work - not visible until they're selected by various links throughout the site.

       

      I've already built much of the site and imported numerous videos and everything works, but lately when I import video, it comes in at the wrong frame size and aspect ratio.  It's happening even if I re-import video files that were already successfully imported.  If I create a new project and import video into it, the video comes in at the proper size and aspect ratio.  I've tried restarting the computer, recompressing the video, and deleting Edge Animate preferences, but these don't resolve the issue.

       

      I'm using the latest version of Edge Animate CC 2014 (2014.0.1).  Here are my system specs:

       

      OS:  Windows 8 Pro (fully updated)

      Processor: Intel Core i7-3930 3.2Ghz

      Ram:  64Gb

      Video Card: NVidia GeForce GTX680

       

      Any assistance would be greatly appreciated!

        • 1. Re: Edge Animate large project video import bug
          vivekuma Adobe Employee

          Can you share the composition for us to test it out?

          • 2. Re: Edge Animate large project video import bug
            JPomonik Level 1

            Thanks so much for getting back to me!  I sent a link to download the project folder to you via the forum's email system.  Please let me know if you don't get it.

            • 3. Re: Edge Animate large project video import bug
              vivekuma Adobe Employee

              Hi,

               

              I looked at the composition, and I do find some issues with the video metadata. Since Edge is sometimes finding hard time to get the video metadata, it is not able to size the imported video automatically to its original size and aspect ratio. The size you are seeing is the default size of the video.


              Workaround: You can very well resize the imported video manually, and work accordingly.

               

              But the published content when open in the browser, works fine. Right??

               

              Regards,

              Vivekuma

              1 person found this helpful
              • 4. Re: Edge Animate large project video import bug
                JPomonik Level 1

                Hello,

                 

                Thanks so much for reviewing the composition.  I've found that the video comes in at different sizes at different times.  And I initially tried to resize the video, but the aspect ratio was different than it should be - so other elements in the composition such as the video border and "close" button don't line up properly.  When I tried to change the aspect ratio within Edge, the grab handles of the asset change, but the video image area stays at the wrong aspect ratio.

                 

                When I preview the existing composition in a browser, everything looks fine.  But all the video that's in there was imported before this problem arose.  If it's a metadata issue, why would all the video that's in there import correctly, then suddenly all videos come in incorrectly, including videos that imported correctly before?

                 

                Regards,

                 

                - Joel

                • 5. Re: Edge Animate large project video import bug
                  vivekuma Adobe Employee

                  Hi,

                   

                  In general, when you import a video, it gets a default size of 320px X 45px. And if video metadata is loaded then the video gets resized to the original size.

                   

                  As in your case, sometimes video when imported remains at the default size (which is Edge Animate bug), but you can explicitly set the height and width of that video in the properties panel.

                  And you can get the original height and width of any video in Windows by looking at the properties of the video file under "Details" tab.

                  Use this height and width of the video and set in the properties panel. This will give you the correct aspect ratio of the video.

                   

                  hth,

                  Vivekuma

                  • 6. Re: Edge Animate large project video import bug
                    JPomonik Level 1

                    Hello,

                     

                    As I mentioned above, when I resize the video to the correct dimensions and aspect ratio, the grab handles change to the correct size, but the image area stays at an incorrect aspect ratio.  See the image below.

                     

                    I wish it were just as easy as just resizing the video.  That was the first thing I tried.

                    Edge_video_issue.jpg

                     

                    The Edge Animate bug makes it impossible to correct the video's size if it comes in incorrectly.  Is this bug being rectified?

                     

                    And as mentioned before, it was working properly when I began this project - all video was coming in correctly.  Then, suddenly, no video is coming in correctly.

                     

                    - Joel

                     


                    • 7. Re: Edge Animate large project video import bug
                      vivekuma Adobe Employee

                      Hi Joel,

                      It seems like an issue in the version of Edge Animate you are using.

                       

                      When I am trying your composition in a newer version of Edge Animate (yet to release), this problem doesn't exist, and video aspect ratio is maintained as original.

                      It will be released very soon this month.

                       

                      So, please hold till that time.

                       

                      Regards,

                      Vivekuma

                      • 8. Re: Edge Animate large project video import bug
                        JPomonik Level 1

                        Thanks for the info about the new release.  I guess I'll have to wait until it comes out and let you know if it resolves the issue.

                         

                        In any event, I really appreciate your efforts regarding this problem.

                        • 9. Re: Edge Animate large project video import bug
                          JPomonik Level 1

                          Hello again,

                           

                          I installed the newest release, and for a while I was able to import video and it would come in at the correct size.  Then, just like last time, it suddenly wouldn't.  As before, the video comes in at the default size (320x45), and as pictured above, when I resize it, it retains the incorrect default aspect ratio.

                           

                          Also as before, if I create a new composition, the video comes in correctly.  I even tried copying it from a new composition into my composition, but it still copies in with the wrong aspect ratio.

                           

                          The newest release has also introduced new bugs, but perhaps they should be addressed in a different thread.  For instance, "Preview in Browser" no longer works - nothing displays at all.  But, if I open the main HTML file in my browser, it works fine.

                           

                          - Joel

                          • 10. Re: Edge Animate large project video import bug
                            vivekuma Adobe Employee

                            Hello Joel,

                            I dragged multiple videos from library panel, also importing videos directly on stage, but although it takes time but everytime video gets expanded to its the original resolution.


                            Is it happening very frequently for you or just sometimes?

                            I tried multiple times, I couldn't repro the issue even a single time. I am using the same composition you shared earlier.

                            • 11. Re: Edge Animate large project video import bug
                              JPomonik Level 1

                              Hi,

                               

                              As I mentioned, it worked for me as well and I was able to import several more videos.  Then, suddenly, no video would import correctly.  If I create a new composition, or use the old one as you did, it works fine.  So, I've uploaded the latest project so you can test it on your end.  I'll send the link via a separate email.

                               

                              Thanks again!

                               

                              - Joel

                              • 12. Re: Edge Animate large project video import bug
                                JPomonik Level 1

                                It's been a while, so I thought I'd check in.  Did you have a chance to download the latest project and test it on your end?  Can you confirm that this is a bug that will be addressed, and/or is there a work-around?

                                 

                                I suspect you're quite busy given all the other bugs in the latest release, but would greatly appreciate any feedback you can provide.

                                • 13. Re: Edge Animate large project video import bug
                                  Vinod Menon@Adobe Adobe Employee

                                  Hi JPomonik,

                                   

                                  We try to repro this on our side. Vivek is on vacation this week. He will respond next week. Sorry for the delay.

                                   

                                  Regards
                                  Vinod Menon

                                  Edge Animate Team

                                  • 14. Re: Edge Animate large project video import bug
                                    JPomonik Level 1

                                    Hello Vinod and Vivek,

                                     

                                    It's been almost a month since your last message.  I'm unable to progress with my project.  Did you test the latest project on your end?  Is a solution forthcoming?

                                     

                                    Thanks and regards,

                                     

                                    - Joel

                                    • 15. Re: Edge Animate large project video import bug
                                      JPomonik Level 1

                                      I still haven't heard back regarding this issue.  In the meantime, I've installed the latest version of Edge Animate (2014.1.1) and it hasn't resolved this problem.

                                      • 16. Re: Edge Animate large project video import bug
                                        vivekuma Adobe Employee

                                        Hi JPomonik,

                                         

                                        First, sorry for the late response as we have been busy with our new patch release.

                                         

                                        Now coming to the issue:

                                             1. We were unable to reproduce the issue, everytime we are dragging the video from library, the video comes in the right resolution/aspect-ratio.

                                             2. Still, if you are getting video on stage in wrong aspect-ratio (with empty space above and below it), you can do the following:

                                                  a. Just check the properties of the vidoe, and note down its size.

                                                  b. Now, change the video element size from Edge Properties Panel, to the dimensions noted.

                                                  c. Now if you want to resize the video, press the "shift(Windows)/option(Mac)" button and drag the video by any of its corner diagonally. "shift/option" will restrict the video aspect ratio from changing.

                                         

                                        hth,

                                        Vivekuma

                                        • 17. Re: Edge Animate large project video import bug
                                          JPomonik Level 1

                                          Hi,

                                           

                                          Thanks for getting back to me.

                                              

                                          As mentioned before, I know how to resize the video – the problem was that once it comes in incorrectly, the visible aspect ratio (black area) cannot be changed.  To help clarify, here’s a summary of exactly what happens:

                                           

                                          When I import the video, no matter what size or aspect ratio it actually is, it comes in at 320x45 – but the black image area is 90x45 (a 2:1 aspect ratio).  See attached image.

                                           

                                          Edge_video_issue2.jpg

                                            

                                          When I resize the video to the correct frame size, the grab handles extend to the proper size, but the black image area remains at the 2:1 aspect ratio.  See the image in this discussion provided on October 2, showing a 720x405 video with the black area still at 2:1 (720x360).

                                             

                                          Since I didn’t hear back from you, I did some additional testing.  Even though the black area indicates an incorrect aspect ratio, if the video is resized to the proper frame size, it plays properly – filling the entire frame represented by the grab handles. So, the bug doesn’t affect how the video plays when previewing the project in a browser, it only affects how it appears when working with it in Edge Animate.

                                             

                                          At this point, I’ll consider the issue closed since I’ve discovered I can work around it.  I hope the info in this discussion can assist anyone else who encounters this issue.  However, I would appreciate your team looking into why video comes in at an incorrect size, and why the black image area appears incorrectly.  This makes it difficult to line things up when working with the video in Edge Animate.

                                             

                                          Thanks again for your attention to this issue and for your assistance.

                                           

                                          Regards,

                                              

                                          - Joel

                                          • 18. Re: Edge Animate large project video import bug
                                            vivekuma Adobe Employee

                                            Hi Joel,

                                            Glad atleast everything is working fine on the browser at least.

                                             

                                            And like I said earlier, we tried reproducing this issue, but not even a single time I faced this issue.

                                            And I think, on your system this issue is specific to that very composition only, and it doesn't occur with the new composition. Right?

                                             

                                            -hth,

                                            Vivekuma

                                            • 19. Re: Edge Animate large project video import bug
                                              JPomonik Level 1

                                              Yes, as noted in my original post, the issue only occurred after a large number of videos were imported.  The issue doesn't occur in a new composition.