2 Replies Latest reply on Oct 2, 2014 11:45 AM by Shawnny Canuck

    Silent Print and Annoying Printing Security Prompt

    Shawnny Canuck Level 1

      Hello all,

       

      I finally managed to get my silent print JavaScript to work but I can’t figure out how to get rid of the annoying security prompt "This document is trying to print. Do you want to allow this?". I tried adding the JavaScript folder to the trusted sites under Security (Enhanced) but I am still being nagged with this prompt. Is this feature only for PDF files or can it be used for JavaScript files? I added a button so the user can just click and the PDF document will save in a specified location using PDFCreator. Yes, I know it is strange that I am printing a PDF file to a PDF but I have my reasons. Is it possible to get rid of this message or am I going to have to put up with it. Here is my code:

       

      function silentprint()
      {
      var pp = this.getPrintParams();
      pp.interactive = pp.constants.interactionLevel.silent;
      pp.printerName = 'PDFCreator';
      this.print(pp);
      }

       

      function toolbar()
      {
      app.beginPriv();
      app.addToolButton({
      cName: "myToolButton",
      cLabel: "Flatten Active Form",
      cExec: "silentprint();",
      cTooltext: "Click to flatten active form.",
      cEnable: true,
      nPos: 0
      });
      app.endPriv();
      }


      toolbar();

        • 1. Re: Silent Print and Annoying Printing Security Prompt
          EnterpriseHelp Adobe Employee

          Hi Shawnny,

           

          Here are a few points:

           

          • You can (or should be able to) bypass the security warning on your machine.
          • There is no way you can set up the doc so other users won't see that warning. Security prefs are on by default.
          • Setting up a privileged location should work. Try trusting the file and/or the folder on your machine.
          • If that doesn't work, choose to Trust Always from the yellow message bar.
          • If that doesn't work, look at the registry and see if you file is indeed trusted for silent printing and JavaScript. Details here: 9   Trust Methods — Acrobat Application Security Guide. Feel free to post your registry prefs here.
          • The last option is un-check Enhanced Security in your preferences.

           

          hth,

           

          Ben

          • 2. Re: Silent Print and Annoying Printing Security Prompt
            Shawnny Canuck Level 1

            Hi Ben,

             

            I added the JavaScript file and folder on my machine to the privileged locations but the print prompt is still showing up. As for the yellow message bar with trust always I do not get that option I simply get a print yes or no. I am running Windows 7. Lastly, I tried unchecking enhanced security in preferences and same thing. I don't want to mess around with the registry mainly because this is a work computer. No worries I will just deal with it I appreciate the help. Thanks.