2 Replies Latest reply on Oct 30, 2007 3:57 AM by cf_rog

    Web Service Error

    Dinghus Level 1
      I have a number of webservices running fine on my website such as Amazon. But now I'm moving to a new hosting service and when I put them up ALL my wsdl calls give me the exact same error:

      Could not generate stub objects for web service invocation.

      Anybody know what the fix for this is? Remember, these all work on my current host.
        • 1. Re: Web Service Error
          insuractive Level 3
          I hate that error message - its just about the most useless one out there. Not exactly sure what could be the problem if your current host and your new host environment are identical. You could try troubleshooting the following:

          1) If you are moving from windows -> linux hosting it could be an issue with case sensitivity
          2) If you can remote connect to your new hosting box, try connecting to the WSDL's using a browser to make sure there isn't anything blocking your connection
          2a) If you don't have access to the box, try performing CFHTTP calls to the WSDL's instead.
          3) Make sure the WSDL locations are refreshed in the CF administrator (if you are using shared hosting, its possible that someone else tried to connect to an older version of the webservices and the CF webservice wsdl definitions are cached on your machine)
          4) Check with your hosting provider to see if you need to use a proxy server for webservice calls from your server.

          I know that's not incredibly helpful, but hopefully one of those will point you in the right direction.
          • 2. Re: Web Service Error
            cf_rog
            I'm having the same problem calling two different web services using MX 6.1.0.

            I can see both wsdls in a browser - but when using CFINVOKE or CreateObject to test connecting I get the "Could not create stub objects" message.

            Using CFHTTP to post the parameters gives 'Connection Failure'.

            When trying to add the web services in CF adminstrator I get "Error creating web service. Please ensure that you have entered the correct url".
            Should I try deleting the files under /CFusionMX/stubs & restarting CF?

            Thanks for any advice
            R