1 Reply Latest reply on Oct 3, 2014 6:56 AM by m_vargas

    We have an older apple computer with safari version 5.1.10 and snow leopard version 10.6.8 do you have something compatable?

    older computer

      Does adobe make a version for a older apple computer, with a safari version 5.1.10 and snow leopard 10.6.8 .