2 Replies Latest reply on Oct 6, 2014 12:56 AM by andrewi106

    Decimal separation by full stop

    andrewi106

      Hi,

       

      I upgraded from InDesign CS6 to CC 2014.

       

      When I open documents with tables containing numbers the decimal separations were replaced with commas (,) instead of full stop (.). These tables are linked to Microsoft excel files. How can I change the separators back to full stops?

       

      Regards,

        • 1. Re: Decimal separation by full stop
          Joel Cherney Adobe Community Professional & MVP

          I haven't seen this - but I rarely use Excel. I suspect that something like altering the language settings or something else in Excel will fix the appearance of the linked files in InDesign.

           

          In what language or locale is Excel installed? My experience of Excel is that the appearance onscreen often has very little to do with the actual data stored. So, if you are running Windows in French in France, then Excel will inherit that locale and default to using comma as the decimal separator. If you tell Excel to display using the full stop as the decimal separator instead, then in the formatted grid view you'll see the full stop, but if you look up in the place where you actually enter data it'll use a comma. The same is true of currency values - if you choose a cell format to display as currency in USD, then it'll happily display $4.50, but the data will only be 4.5. Furthermore, the imported table in InDesign will only show the data, not the Excel format.

           

          It's been a while since I had to use Excel in InDesign, so the above may be entirely incorrect. If this really is an artifact of the file conversion, then you may want to try instead to open the old file in CS6, then export IDML to be opened in CC2014. This has fixed many file up-convert problems for me.

           

          If none of the above works, can you share sample files?

          • 2. Re: Decimal separation by full stop
            andrewi106 Level 1

            Thank you Joel, your information was very useful.

             

            It was actually not the language settings of Excel that caused the issue it was my Mac's settings. I went to System Preferences> Language & Text click on the 'Formats' tab and then clicked on 'Customize' next to Numbers and changed it there.

             

            Thanks again for your help.