0 Replies Latest reply on Oct 12, 2014 9:05 PM by Chia Yu Pai

    ExtensionManifest: Wrong symbol '[' in version: Must be a number

    Chia Yu Pai

      I created a InDesign CC 2014 App Extension on CEP 5.2

       

      manifest.xml as following

      --

      <?xml version="1.0" encoding="UTF-8"?>

      <ExtensionManifest xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" Version="5.0" ExtensionBundleId="com.tester.testapp" ExtensionBundleVersion="1.0">

        <ExtensionList>

          <Extension Id="com.tester.testapp.panel" Version="1.0" />

        </ExtensionList>

        <ExecutionEnvironment>

          <HostList>

            <Host Name="IDSN" Version="10.0" />

          </HostList>

          <LocaleList>

            <Locale Code="All" />

          </LocaleList>

          <RequiredRuntimeList>

            <RequiredRuntime Name="CSXS" Version="5.2" />

          </RequiredRuntimeList>

        </ExecutionEnvironment>

        <DispatchInfoList>

          <Extension Id="com.tester.testapp.panel">

            <DispatchInfo>

              <Resources>

                <MainPath>./index.html</MainPath>

                <CEFCommandLine />

              </Resources>

              <Lifecycle>

                <AutoVisible>true</AutoVisible>

              </Lifecycle>

              <UI>

                <Type>Panel</Type>

                <Menu>TestApp</Menu>

                <Geometry>

                  <Size>

                    <Height>500</Height>

                    <Width>400</Width>

                  </Size>

                </Geometry>

                <Icons />

              </UI>

            </DispatchInfo>

          </Extension>

        </DispatchInfoList>

      </ExtensionManifest>

      --

       

      After signed and imported with Extension Manager, Indesign cannot load this extension

      and log file ($HOME/Library/Logs/CSXS/csxs5-IDSN.log) says:

      2014-10-13 11:47:26 : INFO  PlugPlug version : 5.2.0.49

      2014-10-13 11:47:26 : INFO  LogLevel : 1

      2014-10-13 11:47:26 : ERROR An illegal argument occurred while creating the ExtensionManifest: Wrong symbol '[' in version: Must be a number

       

      Please help to solve it, thank a lot