16 Replies Latest reply on Nov 26, 2007 12:27 PM by murrayt5

    Cannot install Flex Builder 2 Eclipse plugin

    emack06
      I downloaded the Flex Builder 2 plugin from the site and when I tried to install it, I get an error saying the install program cannot find the eclipse install directory. Event after I specified the directory to C:\eclipse, which is where my eclipse install is located. The error says it cannot find my eclipse install directory.
        • 1. Re: Cannot install Flex Builder 2 Eclipse plugin
          jack.nicolai
          I am having the same problem installing the Flex Builder 2 Eclipse plugin. The installation keeps returning an error that a directory must be chosen with a valid Eclipse program file and configuration folder. I am on an Intel Mac with OSX 10.4.9. I have installed both Eclipse 3.2 and Eclipse 3.3 in separate directories to test the install. I have tried a number of solutions that were proposed in an Adobe labs forum regarding issues installing installing the Flex 3 plugin just in case some of those might help but to no avail.

          I do not have the same issues installing the plugin in Eclipse 3.2 on a PC running Windows Vista. It installs seamlessly.
          • 2. Re: Cannot install Flex Builder 2 Eclipse plugin
            BusinessFlex
            I am having the same exact issue. The problem is that Windows used the "Read Only" indicator on folders for other reasons since Folders cannot be read only on Windows. The reason you get the cannot find Eclipse folder is because FlexBuilder thinks that your folder is read only. Try to put the folder name in double quotes, "C:\eclipse" and you will get a different message that states that you do not have permission to write to this folder. The bad news is that there is really no way to remove this read only indicator once Windows puts it there and its most likely set on every folder you have.

            Could someone from Adobe PLEASE acknowledge this and help us out. I can share more info if necessary.
            • 3. Re: Cannot install Flex Builder 2 Eclipse plugin
              jack.nicolai Level 1
              Please help me to understand how the read only property is affecting the MAC installation from failing. You response is in reference to Windows. I had no problems installing the plug-in in Windows.
              • 4. Re: Cannot install Flex Builder 2 Eclipse plugin
                lehomerjay
                Even if you are right and BusinesFlex is referring to Windows which maybe doesn't necessarily affect MAC I also have to repeat exactly the same problem and repeat BusinessFlex's pledging "Could someone from Adobe PLEASE acknowledge this and help us out. I can share more info if necessary."

                Greetings
                • 5. Re: Cannot install Flex Builder 2 Eclipse plugin
                  rojy1993
                  quote:

                  Originally posted by: emack06
                  I downloaded the Flex Builder 2 plugin from the site and when I tried to install it, I get an error saying the install program cannot find the eclipse install directory. Event after I specified the directory to C:\eclipse, which is where my eclipse install is located. The error says it cannot find my eclipse install directory.


                  If you are using Eclipse 3.x, you have uninstall it and download Eclipse 2.x!
                  Flex Builder 2 plugin setup is not compatible with Eclipse 3.x

                  Bye!
                  • 6. Re: Cannot install Flex Builder 2 Eclipse plugin
                    levancho Level 3
                    quote:

                    Originally posted by: rojy1993

                    If you are using Eclipse 3.x, you have uninstall it and download Eclipse 2.x!
                    Flex Builder 2 plugin setup is not compatible with Eclipse 3.x

                    Bye!


                    that is not correct, eclipse 2.x is very very old release I don't even thing its supported anymore,
                    flex builder is comparable with eclipse 3.2.x version and most likely its no compartable with 3.3.x version which is cutting edge latest release..
                    • 7. Re: Cannot install Flex Builder 2 Eclipse plugin
                      jack.nicolai Level 1
                      Starting with Eclispe 3.2 Mac is supposed to support the Flex Plugin. I have read quite a bit of documentation about it in addition you can go and download the Mac installer from Adobe(which I was using).
                      • 8. Re: Cannot install Flex Builder 2 Eclipse plugin
                        dkerr
                        sidenote: recently I tried installing FB2 on eclipse 3.3. Couldn't find the .exe error. Had to downgrade to eclipse 3.2 to get it to install.
                        • 9. Re: Cannot install Flex Builder 2 Eclipse plugin
                          MeisterKris Level 1
                          This is still an issue with eclipse 3.4.

                          I didn't even try 3.3 - instead I installed 3.2 as dkerr mentioned and it worked fine.
                          • 10. Re: Cannot install Flex Builder 2 Eclipse plugin
                            Ahmed_El-Rasheedy
                            All - I just found out what is causing the error(s) when trying to install the Flex Builder 2 Plug-in for Eclipse on an XP OS.
                            This is caused by a conflict between the plug-ins installed into your currently installed Eclipse 3.2 and the Plug-ins the Flex Builder 2 Plug-in tries to install. Some how it tries to overwrite some of the Plug-ins and when it fails it throws the message ( "Cannot find Eclipse folder...." or if you put the " " you get "You don't have write permission..."
                            I was able to install the FB2 plug-in after I did a brand new install of Eclipse 3.2 without any plug-ins. I had to re add my plug-ins after. I pointed back to the same workspace so it was not so bad.
                            I know that it is kind of defeating the purpose of a plug-in but it is better then nothing until the Adobe folks acknowledge the issue.
                            • 11. Re: Cannot install Flex Builder 2 Eclipse plugin
                              Zacb
                              quote:

                              Originally posted by: ARashidy
                              I was able to install the FB2 plug-in after I did a brand new install of Eclipse 3.2 without any plug-ins. I had to re add my plug-ins after. I pointed back to the same workspace so it was not so bad.


                              I had a fresh 3.2 install on my PC and Mac and wasn't able to install it on either.

                              • 12. Re: Cannot install Flex Builder 2 Eclipse plugin
                                Dzihan Level 1
                                Hi,

                                i also have this problem. for now i don't see a way to install flexbuilder plugin 2.01 in eclipse 3.3. eclipse 3.2 works, but i would like to use the latest eclipse version. besides that i get rid of copying around my eclipse 3.2 folder when i need flex on another machine.

                                so please please tell me if you know a solution.

                                Bye!
                                • 13. Re: Cannot install Flex Builder 2 Eclipse plugin
                                  levancho Level 3
                                  why cant you use Flex builder 3? if you want flex 2 sdk you can change flex builder 3 ti use flex 2 sdk.( I think thats your only shot towars eclipse 3.3 compartibility)
                                  • 14. Re: Cannot install Flex Builder 2 Eclipse plugin
                                    Zacb Level 1
                                    quote:

                                    Originally posted by: levancho
                                    why cant you use Flex builder 3?


                                    Any number of reasons. Do you have any insight into this particular problem at all?

                                    • 15. Re: Cannot install Flex Builder 2 Eclipse plugin
                                      dougb1
                                      Any update on this issue? I'm trying to install FB2 plug-in to Eclipse 3.3.0 and get a pop-up "Eclipse 3.2 Not Found".

                                      I'm running Mac OS X 10.4.10.
                                      • 16. Re: Cannot install Flex Builder 2 Eclipse plugin
                                        murrayt5
                                        Flex Builder 2 SDK does NOT work on Eclipse 3.3, only 3.2.x

                                        If your set on using Eclipse 3.3, but you want to use the Flex SDK 2, this is what I did.
                                        Install Eclipse 3.2.x
                                        Install Flex Builder 2 SDK
                                        Install Eclipse 3.3.x
                                        Install Flex Builder 3 SDK beta
                                        Remove Eclipse 3.2
                                        In Eclipse 3.3, in the Preferences (Window menu on Windows, Eclipse men on Mac) --> Flex --> Installed Flex SDKs, here you can set the Flex Builder 2 SDK to be the default SDK for your Flex projects. You can also set this on a per project basis (this Flex app SDK 2, this one SDK 3).