5 Replies Latest reply on Oct 20, 2014 12:21 PM by ktbFL

    Why won't the PDF open from Webhelp

    ktbFL Level 1

      So... I am using RH10 to generate Webhelp. I am on Windows 7.

       

      That said, I have a very small test project I am building for a presentation today.  I have placed a special icon in my help that has an attached PDF file.  The purpose is to have the user click the icon to display the PDF (also a very small file).  However, I have tried setting it up as a hyperlink and via image map... and set it to open in a "new window".  When I rollover the icon with the mouse, it changes to the hand cursor as if it knows it's hyperlinked.  But, when I click or double click on the icon nothing happens.

       

      What  have I missed?  HELP!  This is due this afternoon for a meeting!

        • 1. Re: Why won't the PDF open from Webhelp
          Captiv8r Adobe Community Professional & MVP

          Hi there

           

          First off...

           

          tmp1.png

           

          Are you testing this locally? If so, are you using Microsoft Internet Explorer as your browser? Assuming that's the case, the browser is likely prohibiting links like that from working. One way around this is to simply upload the WebHelp to a web server. If you cannot do that, you need to relax IE's nervous nellie security. So look at your Options for IE and head to the Advanced tab. In the Security section, enable the option to allow active content.

           

          tmp2.png

           

          Let us know how you get on... Rick

          • 2. Re: Why won't the PDF open from Webhelp
            ktbFL Level 1

            Thanks Rick for your response... but boy... are you gonna be sorry! [?]

             

            Unfortunately, things have gone from bad to worse... so here's what's

            happening (or rather not happening).. even after making the security

            setting as you state... and it's happening with chrome as well.. and yes..

            I'm running it locally... we have to be able to run it locally for folks

            that will be trying to access it without internet access... so here's the

            full situation as it stands now:

             

            IN WEBHELP:

             

            1) PDF still isn't opening (it is set to open in New Window)

            2) the video link i have to a quick vid on youtube IS working

            3) the TOC, Index, and Search options aren't working - the nav pane is

            showing up on the left, but it's empty.. and the search field is there, but

            not working.

            4) Image maps aren't working if set to go to a bookmark on the same page.

            If the map is set to link to a different page it works fine... Just not if

            the flag is on the same page (in dropdown text).

             

            IN A CHM:

            I tried generating a chm to see if the same issues occurred... here's what

            happens:

             

            1) PDF still isn't opening (it is set to open in New Window)

            2) the video link i have to a quick vid on youtube IS working

            3) the TOC, and Search options DO work, but Instead of an Index tab,

            there's a Favorites tab and I can't see where I've missed setting the Index

            up.

            4) Image maps work to go to a bookmark on the same page (altho they don't

            work to actually open the dropdown text where the bookmark resides - but

            I'll take what I can get.

             

            I'm having a hard time breaking habits set from working in Flare for over 5

            years.... but I'm trying to remember and cover all bases, but I am

            obviously missing SOMETHING!

             

             

            Am I being too blonde or what?

             

            THANKS!

            • 3. Re: Why won't the PDF open from Webhelp
              ktbFL Level 1

              Also, I've applied a skin, but it's not working either...

              • 4. Re: Why won't the PDF open from Webhelp
                Peter Grainge Adobe Community Professional (Moderator)

                There was a spate of browser issues some months back and Adobe issued a number of patches including one for Rh10.

                 

                Take a look at RoboHelp Patches and Updates | WvanWeelden.eu

                 


                See www.grainge.org for RoboHelp and Authoring tips

                 

                 

                @petergrainge

                • 5. Re: Why won't the PDF open from Webhelp
                  ktbFL Level 1

                  OK... FINALLY GOT ALL THE PATCHES downloaded... and lo and behold... THERE

                  IS MY TOC AND INDEX!   WOOOOHOOO... THANK YOU PETER GRAINGE!  I  you for

                  sure!

                   

                  On Fri, Oct 17, 2014 at 12:27 PM, Peter Grainge <forums_noreply@adobe.com>