3 Replies Latest reply on Nov 15, 2014 5:03 AM by loopback

    Adobe Lightroom 3

    jazzest

      Is Adobe Lightroom 3 (Ver. 3.6/Camera Raw 6.6) compatible with Apple's new Yosemite OSX?