1 Reply Latest reply on Oct 23, 2014 6:31 PM by aliadobeforum

    Digital Rights Management issues with my Kobo Glo

    aliadobeforum

      I have recently run into issues with reading library books on my Kobo Glo.  I get the message that my document is not authorized for use with my Adobe ID.  I re-installed Adobe Digital Editions on a new laptop today and activated an Adobe ID, using the same Adobe account I have always had, and still get this message.  I have also performed all the troubleshooting suggested by Kobo - soft reset of my e-reader, factory re-set, re-borrowing the library book, and I still get this message.  What seems to be the issue?  I'm hoping I can get help on this forum - thanks!

        • 1. Re: Digital Rights Management issues with my Kobo Glo
          aliadobeforum Level 1

          I have found the solution to my own issue.  Well after much troubleshooting with my Kobo Glo, and uninstalling and re-installing ADE, I turned to my public library website and in BIG BOLD FONT with LOTS of colour and a BIG LINK to the Adobe website, it stated that they (Toronto Public Library)  "...recommend using version 3.0 or earlier. Version 4.0 is not recommended at this time due to potential privacy issues."  I uninstalled ADE v 4.x.x and installed v 3.0 by following the link provided by my library, re-downloaded my books, replacing any existing epub files, and there you have it - hours of frustration dissolve as I see my books re-appear.  I hope this post helps somebody.