0 Replies Latest reply on Oct 23, 2014 10:20 AM by TheMikeamondo

    Challenging inDesign Crash Issue  - attn Problem Solvers!

    TheMikeamondo

      Hello... been struggling with this for weeks....  And before I begin, I know you should not open and work with InDesign files across a network... AND I have no solution to change our workflow, and the following set up has been working for months without problem.  A lot of this info is about networking, but the questions at the end are about InDesign and how it relates to networks.... so please bear with the long post.... just trying to get the whole thing described up front.... anyway, here it is....

       

      Network

      QNAP NAS 269L drive - Switch - Cisco 325 Router

      6 Windows 7 PCs  - Cisco Router (all hardwired)

      1 Windows Laptop - Netgear Wireless Access Point - Cisco Router

       

      Software

      InDesign CS4, each freshly installed from the original disks and registered with Adobe.

      Photoshop (Ancient) used lightly for batch converting photos and light photo editing.

       

      Workflow

      Most days only 2-3 computers access the drive and use InDesign, but one day per week, we have all six computers copying, editing, pdfing and saving InDesign files at one time.  MOST errors have occurred during this heavy use time, but they have sometime occurred earlier in the week with only 2 or 3 computers working at a time.  All employees access, work with and save the files on the drive and do not make a local copy first.  As mentioned above, this procedure has worked for YEARS and with this particular set up for Months without problem.

       

      The Errors:

      The exact error and extremely varied.... meaning it does not throw the same code every time.  It will normally shut down InDesign when we try to copy, cut or page a page onto another document.  In a weird turn of events, sometimes a document will crash, and then the back up will not open either, as though some basic element has failed.  Other times the backup opens and can be recovered.  Sometimes it shuts down the program and you can still open the file and it will be fine.  A couple times we've been able to isolate a bad jpg (sometimes the error is about a jpg) and once removed the file can be worked with.  Very little about this is consistent... other than it's only with InDesign and mainly during our short period of heavy use in the drive.

       

      What I've done thus far:  Replaced both drives in the Qnap NAS, as the originals were on their 'not recommended list', and upgraded to current firmware.  Reinstalled fresh copies of InDesign CS4 in all computers.  Reinstalled fresh copies of Photoshop in all computers.  Checked cables for loose connections.  Hard reset the Cisco Router while maintaining my settings.  Restarts on everything in the system, of course.  Checked for error logs on my Cisco Router and the Qnap admin.  Nothing showed on the QNap... however.... the Cisco Router does show nearly countless error like this:

      Connection Refused - Policy violation IN=eth0 OUT=eth1 SRC=192.168.1.131 DST=89.105.216.135 DMAC=e4:c7:22:ce:01:54 SMAC=00:0e:04:14:56:33 LEN=40 TOS=0x00 PREC=0x00 TTL=127 ID=7895 DF PROTO=TCP SPT=56289 DPT=80 WINDOW=16392 RES=0x00 ACK FIN URGP=0

      ... which I've researched and seem harmless enough, and have to do with our computers trying to send something to outside computers and that transfer being blocked.  These are almost continuous, and do not correlate to the timing of my InDesign Errors....

       

      SO......   Any ideas on the culprit in the system?  How does InDesign react to a failing Network Drive?  Are these problems what you would expect of a failing drive unit?   Router?   Switch?  Bad Cable?  Or something else?  I know some will say quit working across the network.... but why did it work fine for the last several years and start failing a month ago, with the exact same workload as before?  Any help appreciated!

      Mike