13 Replies Latest reply on Apr 6, 2016 4:58 AM by anony17014062

    Error loading plugins CC 2014

    bunny351 Level 1

      I have build a plugin with AI SDK CC 2014 on Win 7.

      But the plugin cannot be loaded by one customer (CC2014 18.1.0, Win7 ultimate 64-bit).  Only a message pops up with 'Error loading plugins xxx.aip'. The plugin works fine on other machines with the same configuration.

      The function PluginMain() is not called by AI and I cannot find any information why.

      Is there a kind of logging available on AI side to analyze problems while loading plugins?

        • 1. Re: Error loading plugins CC 2014
          LeoTaro Level 4

          Are you sure you are not trying to load a 32 bit version of the plugin?

          On Mac, you get diagnostic information in the console when a plugin fails to load, but I don't think you get anything on Windows.

          • 2. Re: Error loading plugins CC 2014
            JoeBrownNamify

            I just installed Illustrator CC 2014.

             

            I also just installed the SDK for Illustrator CC 2014.

             

            I can't use any plugins I make, or any of the sample plugins.

             

            I get the exact same response: "Error loading plugins."

             

            This is ridiculous. Any solutions?

            • 3. Re: Error loading plugins CC 2014
              TheDollarBill Level 1

              Joe, Unfortunately your symptoms are slightly different than the original posters. Bunny's issue is odd because the plug-in loads on some machines and not others. I'm afraid I'm stumped there.  But Joe, I think we could help you if we had some more information about the process you went through to get your samples loaded. It really could be a lot of things at this point. And it would help to know if you're developing on a windows or mac OS, etc. Did you follow the procedures in the "Getting Started Guide" in the docs folder of the SDK?

              • 4. Re: Error loading plugins CC 2014
                ianl3492155

                Did you ever find the answer to this? I'm having exactly the same problem but on CC2015

                • 5. Re: Error loading plugins CC 2014
                  LeoTaro Level 4

                  The "Error loading plugin" message normally occurs when you are trying to load the plugin in a version of Illustrator that is older than SDK version you built the plugin with (unlikely with CC2015) or because you are trying to load a 32 bit plugin in a 64 bit version of Illustrator (CC2015 is only 64 bit). See this thread:

                   

                  Hello World - not working for 64bit illustrator

                   

                  Or are you really having exactly the same problem as the original poster, i.e. the plugin works on some machines but not others?

                  • 6. Re: Error loading plugins CC 2014
                    ianl3492155 Level 1

                    Yes, works on my dev machine and not on two others (non-dev).

                    Tried all combinations of 32/64 bit and re-installed Illustrator.

                    Finally, in desperation, I've installed VS2013 on one of the machines and the plugin now works - so obviously missing something which VS installs.

                    Took a note of all the things installed with VS2013..and uninstalled VS2013 - left all the installed things still installed (except VS2013) and addin stopped working again..so suspect an update perhaps?

                    In the process of re-installing VS2013 again now

                    Any ideas?

                    • 7. Re: Error loading plugins CC 2014
                      LeoTaro Level 4

                      Sounds like your plugin requires the Visual Studio runtime library dlls. The default project settings are to use the dll versions of the runtime libraries. In your project properties, if you go to "Configuration Properties | C/C++ | Code Generation" you can change the "Runtime library" setting from the dll version to the static library version.

                      1 person found this helpful
                      • 8. Re: Error loading plugins CC 2014
                        ianl3492155 Level 1

                        Thanks for the help with this. I don't have an option to change to static library version, but it WAS set to use the debug DLL's - which of course will not be on the other machines. I changed this to be the standard DLL's and the plugin works fine now. Such a simple answer in the end for something which has been driving me crazy!

                        • 9. Re: Error loading plugins CC 2014
                          LeoTaro Level 4

                          ianl3492155 wrote:

                           

                          I don't have an option to change to static library version

                          Which options do you see in the "Runtime library" drop down. You should see 4 options, debug and release versions and DLL or static versions.

                           

                          but it WAS set to use the debug DLL's

                          Are you giving out a Debug build? You should really use a Release build for distribution.

                           

                          I changed this to be the standard DLL's and the plugin works fine now.

                          If you are going to be releasing your plugin to a lot of users, it is possible some of them may not have the release versions of the VC runtime libraries either. It is always safer to use the static versions unless you are going to include the VC runtime distributable in your installer.

                          1 person found this helpful
                          • 10. Re: Error loading plugins CC 2014
                            westont83885627 Level 1

                            Nice, just building Release fixed me too.

                            1 person found this helpful
                            • 11. Re: Error loading plugins CC 2014
                              anony17014062 Level 1

                              I tried to build an aip file and it works on machines with visual studio (dev machines), but not on consumer ones without VS. I tried setting the properties of the project to use static .lib libraries and regular non debug dlls.Illustrator does not throw and error on startup but does not start the plugin. Do you have any ideas why could that be? The UI html part is running ok.

                              • 12. Re: Error loading plugins CC 2014
                                LeoTaro Level 4

                                By consumer machines, do you mean your own machines without VS or your customers machines? Are you sure the aip file has been installed correctly? There are issues with the ExManCmd tools not working correctly with the latest version of Illustrator.

                                • 13. Re: Error loading plugins CC 2014
                                  anony17014062 Level 1

                                  It is fixed , some dlls were missing