6 Replies Latest reply on Oct 30, 2014 3:29 AM by 10hofnarr01

    embed videos in edge and force outplay in google chrome

    10hofnarr01

      hi guys,

      i have got a problem.

       

      i have to prepare a presentation, for a new product, so i can't tell you yet what it is and how it works.

       

      but for this presentation it is necessary to use google chrome AND the autoplay function.

      my Problem is now that google chrome won't automatically start the video.

      but in every other browser it is working with the native auto play function in edge animate.

       

      for this video i have to disable the controls as well, this is why i have to force the autoplay.

       

      i tried to load the video via youtube with this code:

       

      var youtubevid = $("<iframe/>");

      sym.$("vcontainer").append(youtubevid);

       

      youtubevid.attr('type','text/html');

      youtubevid.attr('width','1920');

      youtubevid.attr('height','1080');

      youtubevid.attr('src','http://www.youtube.com/embed/XXX?autoplay=1');  // url/Video_Id

      youtubevid.attr('frameborder','1');   // 1 | 0

      youtubevid.attr('allowfullscreen','1');   // 1 | 0

       

       

      and it worked.

       

      but today my boss told we won't have internet while we are presenting  :/

      so i have to embed the video in the presentation itself, but as i told you, the nativ auto play function in the panel won't work.

       

      is there another way to force the autoplay, like the script i posted, for videos which are in my presentation?

       

      Sry for my bad english, i am german.

      I hope you understand what i am meaning