1 2 Previous Next 45 Replies Latest reply on Nov 20, 2014 5:49 PM by zm76

    OSX Yosemite, can not update to latest version

    shrf.dbr

      could not update, can't install after deinstallation. Says "installation failed"
      I use a macbook pro, OS X yosemite
      Please help me !

        • 1. Re: OSX Yosemite, can not update to latest version
          jeromiec83223024 Adobe Employee

          You may need to adjust your GateKeeper settings to allow the installation.

           

          In Control Panel > Privacy and Security, make sure that Allow apps downloaded from Mac App Store and Identified Developers is selected.

          • 2. Re: OSX Yosemite, can not update to latest version
            shrf.dbr Level 1

            thanks for your support !
            But that didn't work , is there anything else ?

            • 4. Re: OSX Yosemite, can not update to latest version
              zm76 Level 1

              I believe the standard and/or scripted response is "we cannot reproduce the problem". The methodology seems to be to blame our computers and not their incompetence. There is no solution to this problem; Flash 15 will not install on Yosemite and I believe it has something to do with the application not being sandboxed. Adobe will not give answers, they will just ask you to do a bunch of time wasting song and dance routine while they laugh behind the scenes.

              • 5. Re: OSX Yosemite, can not update to latest version
                shrf.dbr Level 1

                Yeah your statement makes sense , but i will keep bothering them ! Already had the problem with impossible update in Mavericks, but it didn't bother me. When a few days ago my version couldn't be used anymore I got pissed, it is unbelievable that such a big company has no way to give authentically or helpful solitutions while distributing their software to everybody (buggy).

                but one  support team member asked me to try in safe mode, I will do that, probably not gonna work, reply to him and stay hopeful

                • 6. Re: OSX Yosemite, can not update to latest version
                  zm76 Level 1

                  Don't worry - I'm with you. Squeaky wheel gets the grease, after all.

                   

                  I'm going to take apart the offline installer again and see if I can figure out what I missed the last two times I did it.

                  • 7. Re: Re: OSX Yosemite, can not update to latest version
                    jeromiec83223024 Adobe Employee

                    I totally get that it's frustrating when things don't work like you want them to.  That said, venting your frustration without providing good troubleshooting data isn't going to help us get you to a resolution any faster.  There's no grand conspiracy here to deny that you're having a problem; however, until we can figure out what the issue is (which is most easily accomplished by reproducing the problem with a debugger attached), we're not going to get you fixed.  That's why people from the engineering team spend free time here reading and answering questions from you guys.

                     

                    Flash installs fine for the vast majority of Yosemite users, and it was tested with advanced copies of the OS update.  The forums are representative of a self-selecting population, which may give you a false impression about the frequency or severity of the issue.  There are a handful of people complaining about this, and beyond not having permission to write to files which they should have permission to write to, there's no obvious evidence as to what's causing the problem.

                     

                    We're not debating that you're experiencing an issue.  I'm sure you are.  The problem is that unless we have the ability to reproduce the problem, we have no way to debug it.  As you've read in the other threads, we provide some instructions on how to submit logs for analysis.


                    Installation problems are typically caused by something keeping Flash Player in-use, or in more rare instances, a filesystem problem that prevents the installer from writing to the appropriate files.  On Yosemite, this seems to be the Dashboard Client in a lot of instances.  One of the popular widgets probably uses an embedded WebKit instance that keeps Flash in-use, even when Safari is exited.  As we identify the common denominators, we'll make adjustments to future versions of installers to check for those kinds of things and minimize the pain.  The more useful data we can collect from the field, the more we can do to make the experience better.

                     

                    The big variable is that in the vast majority of instances where people are experiencing problems, we're probably not talking about a fresh Yosemite install.  We're talking about a machine that has been in use for a long time doing a variety of stuff that we can't predict, and that has accreted a bunch of cruft and interesting settings through multiple OS updates and lots of software installation and web browsing.  We've upgraded a few machines from 10.9 to 10.10, but the matrix of things to test quickly becomes unachievably large if you start thinking about "let's test every single conceivable scenario against a 10.10 machine, and then repeat it for machines upgraded through every possible permutation of upgrade from 10.x through 10.10 on every hardware variant, and with both administrative and regular user accounts".  We're testing mostly on clean OS installs, because there is a finite amount of time and resources available to test with, and Yosemite covers about 2% of all web browsing at best.

                     

                    That said, I'm very interested in knowing whether or not booting into Safe Mode and doing a clean uninstall/reinstall of Flash Player works for you.

                     

                    Download the payloads here:

                    Uninstaller: Uninstall Flash Player | Mac OS

                    Offline Installer: http://fpdownload.macromedia.com/pub/flashplayer/current/support/install_flash_player_osx. dmg

                     

                    Then boot into safe mode:

                    OS X: What is Safe Boot, Safe Mode? - Apple Support

                     

                    Then run the uninstaller, followed by the offline installer.

                     

                    If you still run into problems, let us know.

                    • 8. Re: Re: OSX Yosemite, can not update to latest version
                      shrf.dbr Level 1

                      I really understand that, and that you take the time helping us.

                      but the thing disturbed me a lot, is that I went through the routine methods , nothing works and it took a few days to respond.

                      but thanks for taking time now!

                      I Will do that, but in the meanwhile I would ask you to let me know how to get the best debugger in order to provide you with information to for solving.

                       

                      best regards

                      • 9. Re: Re: OSX Yosemite, can not update to latest version
                        shrf.dbr Level 1

                        install in safe Mode did not work ..

                        AMaldonado tried to repair the disk and user rights, but that didnt work either.

                        • 10. Re: Re: OSX Yosemite, can not update to latest version
                          zm76 Level 1

                          Safe mode not working here either. I also must say that, having developed for the Macintosh platform since 1998, if your software needs to be installed in safe mode, then something is wrong with your software. I can also say that my situation is not some kind of anomaly, as I do not update to new OS revisions -- I wipe everything and do a fresh install. I don't know if this is relevant.

                           

                          Let us get some elementary questions out of the way that may assist all involved and help get this resolved. I have (again) disassembled the Flash Player pkg with Pacifist in order to get at the underlying components and extracted the plugin file, which appears to be compressed with the standard lzma file compression (from the dot-lzma extension). I cannot, however, get any lzma tool to recognise the format. This could be contributing to the failure to install -- i.e., the plugin won't expand. What is used to expand the plugin? It is unlikely that the installer binary handles this, as failed installs leave the compressed plugin in the expected location. Screen shots showing that xar or xz will not work on the compressed plugin:

                           

                          xar doesnt recognise.png

                           

                          xz tools doesnt recognise.png

                           

                          Pacifist opened installer pkg, showing the compressed plugin:

                           

                          Flash Player pkg.png

                           

                          System logs also indicate a problem writing to a folder in the home directory. This occurs even if the binary in the offline installer app bundle is run with sudo.

                           

                          11/8/14 18:54:22.444 Adobe Flash Player Install Manager[2613]: Persistent UI failed to open file file://localhost/Users/zm76/Library/Saved%20Application%20State/com.adobe.flashplayer.ins tallmanager.savedState/window_1.data: Permission denied (13)

                          11/8/14 18:55:17.981 authexec[2652]: executing /Library/Application Support/Adobe/Flash Player Install Manager/fpsaud

                           

                          Here is the aftermath of a failed install, even after the uninstaller is used. The compressed plugin lingers.

                           

                          Screen Shot 2014-11-08 at 19.03.15.png

                          • 11. Re: Re: OSX Yosemite, can not update to latest version
                            jeromiec83223024 Adobe Employee

                            As an expert developer, I'm sure that you can appreciate that we're simply troubleshooting.  Booting into safe mode eliminates the possibility that the installed player is in-use and ensures that the filesystem is in a consistent state.  It seemed like a reasonable troubleshooting step.

                             

                            Have all of you verified that GateKeeper is set to Allow Apps from the Mac App Store and Identified Developers?  The default changed in Yosemite, and a number of people were reporting messages about the installer .dmg being corrupt when this setting was set to Mac App Store only.

                             

                            We did some Yosemite-related work to the installer in the upcoming release (moving to V2 signing, etc).  Do you get better results installing the latest beta?

                            http://labsdownload.adobe.com/pub/labs/flashruntimes/flashplayer/flashplayer15_install_mac .dmg

                            • 12. Re: Re: OSX Yosemite, can not update to latest version
                              zm76 Level 1

                              I keep Gatekeeper off. Popping off to check the package offered in your post.

                               

                              Screen Shot 2014-11-09 at 02.59.15.png

                              • 13. Re: Re: OSX Yosemite, can not update to latest version
                                zm76 Level 1

                                Gets even less far than the stable package. Same errors.

                                 

                                Screen Shot 2014-11-09 at 03.10.35.png

                                Screen Shot 2014-11-09 at 03.09.41.png

                                • 14. Re: Re: OSX Yosemite, can not update to latest version
                                  zm76 Level 1

                                  How do I uncompress the plugin? If I could do that, then I could install it manually.

                                  • 15. Re: OSX Yosemite, can not update to latest version
                                    shrf.dbr Level 1

                                    same here : didn't work.
                                    But tis funny that sometimes it stops at 7% , 25%, 75% and so on, even by trying the exact same installer it changes.
                                    How did you get so far m76 ?

                                    • 16. Re: OSX Yosemite, can not update to latest version
                                      zm76 Level 1

                                      I noticed that too. Sometimes 50, 40, 70.

                                       

                                      I am going to extract the pkg from the app bundle and try to install it with the Apple installer to see what happens. I am now determined to fix this.

                                      • 17. Re: OSX Yosemite, can not update to latest version
                                        zm76 Level 1

                                        The flat package fails during the validation stage with the Apple installer and the installer log shows this:

                                         

                                        Nov  9 13:07:15 NRU.local installd[2636]: PackageKit: ----- Begin install -----

                                        Nov  9 13:07:16 NRU.local installd[2636]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Adobe Flash Player.pkg”." UserInfo=0x7fc2a32081f0 {NSFilePath=./postinstall, NSURL=file://localhost/Users/zm76/Downloads/Flash%20idiocy/beta/Adobe%20Flash%20Player.pk g#AdobeFlashPlayerComponent.pkg, PKInstallPackageIdentifier=com.adobe.pkg.FlashPlayer, NSLocalizedDescription=An error occurred while running scripts from the package “Adobe Flash Player.pkg”.} {

                                             NSFilePath = "./postinstall";

                                             NSLocalizedDescription = "An error occurred while running scripts from the package \U201cAdobe Flash Player.pkg\U201d.";

                                             NSURL = "file://localhost/Users/zm76/Downloads/Flash%20idiocy/beta/Adobe%20Flash%20Player.pkg#Ado beFlashPlayerComponent.pkg";

                                             PKInstallPackageIdentifier = "com.adobe.pkg.FlashPlayer";

                                          }

                                        Nov  9 13:07:17 NRU.local Installer[10755]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

                                        Nov  9 13:07:17 NRU.local Installer[10755]: Displaying 'Install Failed' UI.

                                        Nov  9 13:07:17 NRU.local Installer[10755]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

                                        • 18. Re: OSX Yosemite, can not update to latest version
                                          zm76 Level 1

                                          OK, I used Pacifist to install with no errors, but I still get a compressed plugin in the Internet Plugins folder:

                                           

                                          Screen Shot 2014-11-09 at 13.15.36.png

                                           

                                          The prefs pane cannot find the plugin:

                                           

                                          Screen Shot 2014-11-09 at 13.16.15.png

                                           

                                          I am ready to say that the problem is definitely that the plugin is not being uncompressed. There are no scripts in the flat package to handle the uncompression. As far as I can tell, the Adobe installer app bundle does not either (hence the failure to install). I'm going to disassemble the Adobe installer binary to see if I can get a better idea of what it is trying to do. Could take a bit, but I will keep updating this thread as I find things. Jeromie, let's get this fixed -- we'll be the toast of the town.

                                          • 19. Re: OSX Yosemite, can not update to latest version
                                            jeromiec83223024 Adobe Employee

                                            There's a post-processing step that uncompresses the folder.  It's weird that it's failing.

                                             

                                            Is there anything useful in the installer log?  It's at ~/Library/Logs/FlashPlayerInstallManager.log

                                            • 20. Re: OSX Yosemite, can not update to latest version
                                              zm76 Level 1

                                              Here's the bit from the last install using the official installer that I tried:

                                               

                                              2014-11-09 13:14:39 -0500 [I]  IM: ---------- log start ----------

                                              2014-11-09 13:14:41 -0500 [I]  IM: 1387

                                              2014-11-09 13:14:44 -0500 [I]  IM: ---------- log start ----------

                                              2014-11-09 13:14:46 -0500 [I]  IM: 1387

                                              2014-11-09 13:14:46 -0500 [I]  IM: 1387

                                              2014-11-09 13:14:55 -0500 [I]  IM: ----------  log end  ----------

                                              • 21. Re: OSX Yosemite, can not update to latest version
                                                zm76 Level 1

                                                And here's from one I just tried with the beta installer.

                                                 

                                                2014-11-09 15:19:35 -0500 [I]  IM: ---------- log start ----------

                                                2014-11-09 15:19:35 -0500 [I]  IM: All install checks pass

                                                2014-11-09 15:19:47 -0500 [I]  IM: User does not have any processes that need to be closed before the Flash Player can be installed.

                                                2014-11-09 15:19:47 -0500 [I]  IM: [install started]

                                                installer: Package name is Adobe Flash Player

                                                installer: Installing at base path /

                                                installer: The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)

                                                2014-11-09 15:19:59 -0500 [I]  IM: [install completed]

                                                2014-11-09 15:19:59 -0500 [E]  IM: [install failed]

                                                2014-11-09 15:20:03 -0500 [I]  IM: ----------  log end  ----------

                                                • 22. Re: OSX Yosemite, can not update to latest version
                                                  jeromiec83223024 Adobe Employee

                                                  Hmm, not super informative.  I'm still trying to work out a common denominator.  I just did a fresh Yosemite install on my personal machine after I lost the hard disk.  I realized that you probably have XCode installed and I don't.  Anything else that might be relevant?  You have a username with spaces or interesting characters? Non-english default system, etc?  Anything that might mess with the installer (antivirus/antimalware stuff, etc)?

                                                  • 23. Re: OSX Yosemite, can not update to latest version
                                                    zm76 Level 1

                                                    Yes, current XCode installed (6.1).

                                                    No weirdness in the username, just 4 alphanumeric characters (letters & numbers only).

                                                    English system with no other language kits installed.

                                                    I have ClamAV, but it isn't active, i.e., I just run it on demand, so there's no AV stuff in the background poking around where it shouldn't.

                                                     

                                                    I've noticed that both the installer and uninstaller generate errors in the system logs because they can't write to this folder:

                                                    Screen Shot 2014-11-09 at 17.18.58.png

                                                     

                                                    I am going to change permissions so that it has universal write access and see what happens. Will report soon.

                                                     

                                                    Edit: didn't make a difference.

                                                    • 24. Re: OSX Yosemite, can not update to latest version
                                                      jeromiec83223024 Adobe Employee

                                                      I wasn't able to open this folder on my machine either.  I was able to blow it away with a sudo rm -fr on that path.  It doesn't get recreated when I uninstall and reinstall, even after launching both Flash content and the Flash Player control panel utility. 

                                                      • 25. Re: OSX Yosemite, can not update to latest version
                                                        shrf.dbr Level 1

                                                        i am now at the same step you are i think. also have flash installed but without the plugin , which is saved now in the internet plugins as an .izma file.
                                                        Are you trying anything more ? are there any ideas ?

                                                        thanks

                                                        • 26. Re: OSX Yosemite, can not update to latest version
                                                          zm76 Level 1

                                                          I also noticed that the folder did not get recreated. The messages in the system logs about not being to write to it disappeared as well.

                                                           

                                                          I'm stuck in the same place. I've got an install, but cannot uncompress the plugin.

                                                           

                                                          I've got the disassembler and debugger ready to go against the offline installer binary, so I'll see what I can find out over the course of today.

                                                          • 27. Re: OSX Yosemite, can not update to latest version
                                                            shrf.dbr Level 1

                                                            Ok ,  good to know!

                                                            I Have no clue what a debugger is or how to get the log files, I'm not an developer, so I just managed to get the installation dobe with pacifist.

                                                            so thanks a lot for all the effort zm7 !

                                                            No ideas from adobes side Jeromie ?

                                                             

                                                            Best regards

                                                            • 28. Re: OSX Yosemite, can not update to latest version
                                                              zm76 Level 1

                                                              Watching the system log is easy. Use Applications -> Utilities -> Console and type "adobe" in the search box in the upper left hand corner.

                                                               

                                                              Screen Shot 2014-11-10 at 11.33.47.png

                                                              • 29. Re: Re: OSX Yosemite, can not update to latest version
                                                                jeromiec83223024 Adobe Employee

                                                                Alright, it's Monday and I chatted with the engineer that actually works on the Mac installer.  I was hoping I could get you going over the weekend, but no joy.

                                                                 

                                                                • The permission failure on the Application Saved State folder is a known issue caused by the online installer (AdobeFlashPlayerInstaller_15_ltrosxd_aaa_aih.dmg), but should not cause a fatal failure.
                                                                • None of us have seen the LZMA decompression failure before
                                                                • The installation failure appears to be happening while we're executing the postinstall script, but it doesn't really do much, so it's not obvious why it would fail.
                                                                  • Any failures *should* show up in the Console, but we haven't seen anything in the Console that indicates why it's failing
                                                                • postinstall runs the 'finalize' utility included in the package, which does the actual decompression.  Again, failures should show up in the console.

                                                                 

                                                                As you're doing this stuff, I just wanted to confirm that you're using the offline installer (install_flash_player_osx.dmg), and that you're encountering the LZMA failure without using Pacifist.

                                                                 

                                                                Also, we will post a new version of the generally-available release tomorrow, in coordination with Patch Tuesday, but it should be pretty much equivalent to the beta that I pointed you to over the weekend.  You may need to run the uninstaller before proceeding with a new install.

                                                                 

                                                                Anyway, if you're not making any progress on that front, I'm hoping that the pointers to the postinstall and finalize scripts will maybe yield some interesting failure output.

                                                                • 30. Re: OSX Yosemite, can not update to latest version
                                                                  zm76 Level 1

                                                                  I was able to get the 15.0.0.22 to install. Thanks to the info from Jeromie above and partially due to a minor detail I had overlooked here.

                                                                   

                                                                  I used Pacifist to install and extracted the finalize binary to run against it. While I was examining the resources, I looked at postinstall and saw that it shebanged /bin/sh. My /bin/sh is an actual Bourne shell, not just a renamed bash.

                                                                   

                                                                  I swapped the /bin/sh binaries around, uninstalled and was able to install with the offline 222 installer. Thus, advice to the tinkerer: the installer package depends on extensions that are in bash, but not in the Bourne shell. Any scripting I do I keep strict compliance with the Bourne shell as laid out In The Beginning, and do not use bash extensions. Mea culpa.

                                                                   

                                                                  Jeromie, you've been a saint amongst men and a defender of the faith. I applaud you and your efforts to help us get this right.

                                                                   

                                                                  So, to sum it up, at least in my case. The postinstall script was failing and not able to run the finalize binary because of my dogmatic adherence to the original sh. I would, however, offer the advice of changing the shebang in the postinstall to be /bin/bash and not rely on the fact that /bin/sh is a link to /bin/bash.

                                                                   

                                                                  Now, shrf.dbr, does any of this help you out? Not going to leave you out in the cold.

                                                                   

                                                                  Screen Shot 2014-11-10 at 16.01.06.png

                                                                  • 31. Re: OSX Yosemite, can not update to latest version
                                                                    shrf.dbr Level 1

                                                                    well I appreciate a little t that your effort led to a success and that we have a solution

                                                                    but I don't really know has to do it on my own..

                                                                    • 32. Re: OSX Yosemite, can not update to latest version
                                                                      zm76 Level 1

                                                                      Let me put something together. Will post soon, so hang tight.

                                                                      • 33. Re: OSX Yosemite, can not update to latest version
                                                                        zm76 Level 1

                                                                        First, for my own curiosity, could I get a listing of your /bin? Open a terminal, type "ls -GlF /bin" and post it here, please. You might have to expand the terminal a bit to get a good picture. Here's an example (I have the aforementioned ls command aliased, so it looks a little different):

                                                                         

                                                                        Screen Shot 2014-11-11 at 07.23.35.png

                                                                        • 34. Re: OSX Yosemite, can not update to latest version
                                                                          shrf.dbr Level 1

                                                                          ok i will do that , just a few minutes !

                                                                          • 35. Re: OSX Yosemite, can not update to latest version
                                                                            shrf.dbr Level 1

                                                                            Last login: Mon Nov 10 17:52:30 on ttys000

                                                                            Sherif-Dabours-MacBook-Pro-2:~ Sherif$ ls -GF/bin

                                                                            ls: illegal option -- /

                                                                            usage: ls [-ABCFGHLOPRSTUWabcdefghiklmnopqrstuwx1] [file ...]

                                                                            Sherif-Dabours-MacBook-Pro-2:~ Sherif$ ls -GlF /bin

                                                                            total 5120

                                                                            -rwxr-xr-x  2 root  wheel    18480 10 Sep 00:44 [*

                                                                            -r-xr-xr-x  1 root  wheel   628736 27 Sep 04:03 bash*

                                                                            -rwxr-xr-x  1 root  wheel    19552 10 Sep 00:57 cat*

                                                                            -rwxr-xr-x  1 root  wheel    30112 10 Sep 00:50 chmod*

                                                                            -rwxr-xr-x  1 root  wheel    24768 10 Sep 00:49 cp*

                                                                            -rwxr-xr-x  2 root  wheel   370096 10 Sep 00:40 csh*

                                                                            -rwxr-xr-x  1 root  wheel    24400 10 Sep 00:44 date*

                                                                            -rwxr-xr-x  1 root  wheel    27888 10 Sep 00:50 dd*

                                                                            -rwxr-xr-x  1 root  wheel    23472 10 Sep 00:49 df*

                                                                            -r-xr-xr-x  1 root  wheel    14176 10 Sep 01:27 domainname*

                                                                            -rwxr-xr-x  1 root  wheel    14048 10 Sep 00:44 echo*

                                                                            -rwxr-xr-x  1 root  wheel    49904 10 Sep 00:57 ed*

                                                                            -rwxr-xr-x  1 root  wheel    19008 10 Sep 00:44 expr*

                                                                            -rwxr-xr-x  1 root  wheel    14208 10 Sep 00:44 hostname*

                                                                            -rwxr-xr-x  1 root  wheel    14560 10 Sep 00:44 kill*

                                                                            -r-xr-xr-x  1 root  wheel  1394560 10 Sep 01:59 ksh*

                                                                            -rwxr-xr-x  1 root  wheel    77728 10 Sep 01:32 launchctl*

                                                                            -rwxr-xr-x  2 root  wheel    14944 10 Sep 00:49 link*

                                                                            -rwxr-xr-x  2 root  wheel    14944 10 Sep 00:49 ln*

                                                                            -rwxr-xr-x  1 root  wheel    34640 10 Sep 00:49 ls*

                                                                            -rwxr-xr-x  1 root  wheel    14512 10 Sep 00:50 mkdir*

                                                                            -rwxr-xr-x  1 root  wheel    20160 10 Sep 00:49 mv*

                                                                            -rwxr-xr-x  1 root  wheel   106816 10 Sep 00:49 pax*

                                                                            -rwsr-xr-x  1 root  wheel    46688 10 Sep 00:59 ps*

                                                                            -rwxr-xr-x  1 root  wheel    14208 10 Sep 00:44 pwd*

                                                                            -r-sr-xr-x  1 root  wheel    25216 10 Sep 01:27 rcp*

                                                                            -rwxr-xr-x  2 root  wheel    19760 10 Sep 00:49 rm*

                                                                            -rwxr-xr-x  1 root  wheel    14080 10 Sep 00:49 rmdir*

                                                                            -r-xr-xr-x  1 root  wheel   628800 27 Sep 04:03 sh*

                                                                            -rwxr-xr-x  1 root  wheel    14016 10 Sep 00:44 sleep*

                                                                            -rwxr-xr-x  1 root  wheel    28064 10 Sep 00:59 stty*

                                                                            -rwxr-xr-x  1 root  wheel    34224 10 Sep 03:59 sync*

                                                                            -rwxr-xr-x  2 root  wheel   370096 10 Sep 00:40 tcsh*

                                                                            -rwxr-xr-x  2 root  wheel    18480 10 Sep 00:44 test*

                                                                            -rwxr-xr-x  2 root  wheel    19760 10 Sep 00:49 unlink*

                                                                            -rwxr-xr-x  1 root  wheel    14112 10 Sep 01:32 wait4path*

                                                                            -rwxr-xr-x  1 root  wheel   551232 10 Sep 01:19 zsh*

                                                                            Sherif-Dabours-MacBook-Pro-2:~ Sherif$

                                                                            • 36. Re: OSX Yosemite, can not update to latest version
                                                                              shrf.dbr Level 1

                                                                              somehow sending a picture did not work..

                                                                              • 37. Re: OSX Yosemite, can not update to latest version
                                                                                zm76 Level 1

                                                                                Still good. I just wanted to make sure there wasn't anything wrong in your /bin. I have to run out for a few hours, then I will be back to help finish this up.

                                                                                • 38. Re: OSX Yosemite, can not update to latest version
                                                                                  shrf.dbr Level 1

                                                                                  Ok, take your Time !

                                                                                  • 39. Re: OSX Yosemite, can not update to latest version
                                                                                    shrf.dbr Level 1

                                                                                    dont want to hurry you or be impolite , but how is it going ?

                                                                                    1 2 Previous Next