3 Replies Latest reply on Dec 2, 2014 3:42 PM by alex5045 Branched from an earlier discussion.

    Installation Problem on Yosemite (MacOS 10.10)

    zm76

      Running Yosemite (10.10). Using Safari Version 8.0 (10600.1.25)

       

      Not working here in any form. The offline installer quits at 40% and the online installer returns "process not elevated". I've uninstalled Flash and that had no result.

       

      Screen Shot 2014-10-20 at 01.42.09.png

       

      Screen Shot 2014-10-20 at 02.10.10.png

       

       

      I see a few entries like this in the system logs:

      10/20/14 01:43:46.492 Adobe Flash Player Install Manager[7233]: Persistent UI failed to open file file://localhost/~/Library/Saved%20Application%20State/com.adobe.flashplayer.installmanag er.savedState/window_1.data: Permission denied (13)

       

      Here is the relevant part of the installer's log:

      2014-10-20 01:57:12 -0400 [I]  IM: ---------- log start ----------

      2014-10-20 01:57:12 -0400 [I]  IM: All install checks pass

      2014-10-20 01:57:16 -0400 [E]  IM: User has 1 process that needs to be closed before the Flash Player can be installed.

      2014-10-20 01:57:22 -0400 [I]  IM: [install started]

      installer: Package name is Adobe Flash Player

      installer: Installing at base path /

      installer: The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)

      2014-10-20 01:57:32 -0400 [I]  IM: [install completed]

      2014-10-20 01:57:32 -0400 [E]  IM: [install failed]

      2014-10-20 01:58:44 -0400 [I]  IM: ----------  log end  ----------

      2014-10-20 02:20:35 -0400 [I]  IM: ---------- log start ----------

      2014-10-20 02:20:38 -0400 [I]  IM: 1407

      2014-10-20 02:20:43 -0400 [I]  IM: ---------- log start ----------

      2014-10-20 02:20:44 -0400 [I]  IM: 1407

      2014-10-20 02:20:45 -0400 [I]  IM: 1407

      2014-10-20 02:20:49 -0400 [I]  IM: ----------  log end  ----------

       

      It looks like the installer is trying to access that folder as if it were a Windows folder, instead of using shell escapes to include the spaces. A guess.

      Also, the com.adobe.flashplayer.installmanager.savedState is only readable by "system" and no-one else. I cannot access it even as administrator.

       

      Hope this helps.

        • 1. Re: Installation Problem on Yosemite (MacOS 10.10)
          zm76 Level 1

          Also, after the failed off line install process, the following file is left in /Library/Internet Plug-ins. It looks like it should be uncompressed, but isn't. No 7zip decompressor (the most common implementation of the LZMA compression scheme) nor the xz command line tools will open it. It is roughly 15MB in size. This appears to be a problem with the installer package at all levels. Some response would be nice, Adobe.

           

          Screen Shot 2014-10-20 at 12.51.57.png

          • 2. Re: Installation Problem on Yosemite (MacOS 10.10)
            zm76 Level 1

            Still looking for an answer.

            • 3. Re: Installation Problem on Yosemite (MacOS 10.10)
              alex5045

              I am using Yosemite on a MacBook Pro.  When I first tried to use an application that used Flash Player I was instructed to Upgrade the version of my Flash Player.  I tried to do this under both FireFox and Yosemite.  Under both scenarios I went through the update process just fine and at the end of the process the software advised me I had been successful.  I note that the same applications worked fine prior to my installation of Yosemite

               

              I then ran Adobe’s Version checker which responded I had the latest version of Flash Player installed.

               

              BUT

               

              When I try applications that use Flash Player I am instructed to update the version of my copy of Flash Player that is loaded on my MacBook.  Also I am unable to find Flash Player via Finder>Applications

               

              Help

               

              Alex