3 Replies Latest reply on Nov 11, 2014 2:17 AM by mavidef1973

    Data & Services > Data Sources

    jumajii

      I'm changing from CF9 to CF11 and I have already purchased licenses. But I can not find the option to set the informix driver that is not in the list of available drivers !!!

       

      driver.gif

        • 1. Re: Data & Services > Data Sources
          mavidef1973

          I have the same problem !!!!

          • 2. Re: Data & Services > Data Sources
            haire

            i think u should use the 'other'
            and then put some connection string to the informix database.

             

            ConnStr = "Provider=MSDASQL; DRIVER={INFORMIX 3.82 32 BIT}; " & _

            "DB=DataBasName; HOST=HostName;" & _

            " SRVR=ServerName; SERV=9400; PRO=onsoctcp; " & _

            " UID=UserName; PWD=Password; "



            Adobe ColdFusion 9 * Connecting to Informix

            • 3. Re: Data & Services > Data Sources
              mavidef1973 Level 1

              Thanks a lot for your reply haire.

              The reason for which i asked is that "informix" jdbc drivers should be included in the select box of drivers in datasource page of Cold Fusion Administrator as it was for CF9.

              In CF 11 documentation it looks supported but it isn't.

              I tried to modify neo-drivers.xml file in cfusion root, mapping informix as default driver for datasources .

              It seems it works now.

              informix.jpg

               

              I established a connection with a data source and the status result is OK.

              I'll test it very soon in .cfm pages and i'll post the issues when i'll find them.

               

              This is the procedure i used:

               

              I opened cfusion/lib/neo-drivers.xml and i added this

               

              <var name='Informix'><struct type='coldfusion.server.ConfigMap'><var name='port'><string>"PortNumber"</string></var>

              <var name='class'><string>macromedia.jdbc.MacromediaDriver</string></var>

              <var name='name'>

              <string>Informix</string></var>

              <var name='handler'><string>informix.cfm</string></var>

              <var name='url'>

              <string>jdbc:macromedia:informix://[host]:[port];informixServer=[informix_server];Database Name=[database];sendStringParametersAsUnicode= [sendStringParametersAsUnicode];querytimeout=[qTimeout];[args]</string></var>

              <var name='vendor'><string>Macromedia</string></var></struct></var>

               

              I'd like to know if there is another way to solve the issue and the reason for which i had this problem. Maybe the new Tomcat release?

              Thanks again