2 Replies Latest reply on Nov 8, 2014 10:50 PM by btelsh

    Used to have auto-centering, now it's turned off?


      When I first got InDesign, things would auto-center with a green or pink line depending on what I was trying to align. Lately this isn't appearing at all.


      I could also see the spacing between different boxes and see if they were aligned. How can I turn this option back on?


      I'm currently running InDesign CC.

        • 1. Re: Used to have auto-centering, now it's turned off?
          Cari Jansen Adobe Community Professional



          The feature you describe is called Smart Guides. It sounds like you've somehow disabled them.


          To show or hide Smart Guides:

          • View menu > Grids and Guides > Smart Guides


          If that doesn't work, the Smart Guide Options in the preferences might have been disabled.


          To control which Smart Guide Options are enabled:

          • (Mac) InDesign > Preferences > Guides and Pasteboard
          • (Win) Edit > Preferences > Guides and Pasteboard
          • Ensure the Align To and Smart Dimensions and Smart Spacing settings are selected.


          Also although Smart Guides will display when you are 'previewing' your document, they are easiest to work with when the Screen Mode you're working in is set to Normal. (View > Screen Mode > Normal), and when not working in Overprint Preview (View > Overprint Preview).


          Hope this helps.



          • 2. Re: Used to have auto-centering, now it's turned off?
            btelsh Level 1

            Thanks Cari!


            I read your advice and the Smart Guides was greyed out and unavailable to click.

            It turns out Smart Guides was disabled because I somehow turned on the "Snap to document grid." I found the solution here.




            Thank you for helping me figure out what the actual Smart Guides were called!