0 Replies Latest reply on Nov 12, 2014 7:30 PM by brookhaj

    LR3 not importing images

    brookhaj

      Hello, I have been using LR3 for nearly 3 years now, and suddenly I'm having trouble importing images.  I always import the images from my camera into iPhoto and then drag the ones I'd like to edit into a folder on my desktop (mac).  Then I try to import by selecting the folder and then checking the images I wish to import.  Today was the first time that it did not import all of the images.  After selecting 15 images, it only actually imported 3.  The next time I tried it, it imported 3 more.  Then it would go back and forth from importing one or none.  It currently has been trying to import 3 files for the past 20 minutes and has a progress bar at the top that says "Importing files at their current location" and "Import in progress..." on the screen but it seems to nearly be frozen.  Sometimes it allows me to "x" out of the import and other times it doesn't.  I've tried quitting and restarting the program several times with no luck.  Help, please!