4 Replies Latest reply on Nov 13, 2014 2:21 PM by jmbriet

    Lightroom 5.6: compatible with OS X Yosemite?

    jmbriet Level 1

      Is this version compatible with Apple's latest OS ( Yosemite ) ?

       

      Thanks, John M Breitigan