29 Replies Latest reply on Feb 11, 2010 8:32 PM by simonphp

    Flex Module Issues

    johnbarrett1 Level 1
      Please help!
      I was not able to locate my apache configure file during the installation!
      I know it is at /etc/httpd on my mac, but how do I do this during the install. I don't think that there is an option to install with terminal? I don't know how to tell the folder system to look at the root to fins apache.

      Can anybody please help me install this. I am a newbie just learning, and this will be so useful to me.
      Thanks,
      john (johnbarr@hawaii.edu0
        • 1. Re: Flex Module Issues
          catalinanastasoaie Level 1
          Hi,

          In order to do that you just start the installation again and in the step where you are asked for the your apache click on the Browse button and in the right top of the window that just opened you have a search box. In that search box type /etc/httpd and you should be taken to the apache root. After the installation finishes you just need to restart your apache and the module should be installed and working on your computer.

          Regards,
          Catalin Anastasoaie
          • 2. Re: Flex Module Issues
            johnbarrett1 Level 1
            if anybody else had this issue, in the "search box" type "/etc/httpd" this worked, and it did install, but when I try to view a mxml page(even the samples) all I see is the text, and not the flex app!

            Something much be really wrong, this would have been so cool:(
            • 3. Re: Flex Module Issues
              catalinanastasoaie Level 1
              Have you restarted the apache after the installation finished? If not try restarting it and then refresh your samples page. This should work

              -catalin
              • 4. Re: Flex Module Issues
                johnbarrett1 Level 1
                Hi,
                Opps, I wrote the next message too soon, as your was not there, sorry.
                I was able to figure out how to tell it where the apache was.

                However, now I have a huge problem! My localhost will not turn back on:(

                I did the whole set up, and everything seemed fine, then I saw your message, restarted the computer, and now the localhost will not load.

                I think that there is an issue with the https.conf file. Not sure if I should delete the flex options in there, but then this will not work.

                I might not be ready for this, as I do not understand how to fix problem when they happen.
                • 5. Re: Flex Module Issues
                  catalinanastasoaie Level 1
                  Could you tell me what error do you get when you try to restart the apache? Open a console and type "sudo apachectl start". Now you should be asked the admin password. After you have typed the password some error/s should appear or your apache server should start.

                  If there are some errors could you paste them here?

                  Paste the lines that contain flex from your httpd.conf too.

                  -catalin
                  • 6. Re: Flex Module Issues
                    johnbarrett1 Level 1
                    Hi catalin,
                    thanks so much for your help`-`
                    when I use "sudo apachectl start:
                    error message:
                    [Fri Mar 16 23:23:56 2007] [warn] Loaded DSO /Applications/JRun4/lib/wsconfig/1/mod_jrun.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
                    Processing config directory: /private/etc/httpd/users/*.conf
                    Processing config file: /private/etc/httpd/users/johnbarrett.conf
                    Syntax error on line 1126 of /etc/httpd/httpd.conf:
                    Cannot load /Users/johnbarrett/flexSamples/flex/modules/mod_flex.so into server: (reason unknown)
                    /usr/sbin/apachectl start: httpd could not be started

                    ----------------------------------------------------------------------------------
                    The flex stuff was easy to find, right under JRun settings at the end. I did check, and the /Users/johnbarrett/flexSamples/flex/modules/mod_flex.so file does exists.
                    Seems like this is the problem, since this file will not load into the server, I think that the localhost of apache does not know what to do, and does not load.

                    In httpd.conf:
                    Include /private/etc/httpd/users/*.conf
                    LoadModule flex_module "/Users/johnbarrett/flexSamples/flex/modules/mod_flex.so"
                    AddHandler flex .mxml

                    Thanks so much for your help,
                    John
                    • 7. Re: Flex Module Issues
                      Ivascu Cristian Level 1
                      Hi John,
                      Could you provide some more details on what happens? Can you start Apache from the command line, but not automatically? Or it does not start at all?

                      Cristian
                      • 8. Re: Flex Module Issues
                        johnbarrett1 Level 1
                        It does not start at all.
                        I tried using the command line, as well as system prefs.
                        it says,"httpd could not be started"

                        thanks for your help!
                        Does it matter where the flex SDK is? I did tell it the correct place to look.
                        • 9. Re: Flex Module Issues
                          jouiselle
                          I have the same problem loading
                          in the apachectl start is says;
                          Cannot load /Users/jou/flex/SDK/modules/mod_flex.so into server: (reason unknown)
                          then quits
                          • 10. Re: Flex Module Issues
                            johnbarrett1 Level 1
                            does you localhost work? if you type using the command line(terminal):
                            sudo apachectl stop it will tell you if it is running. You can type sudo apachectl start to start it.

                            I am not sure what the problem is, but hopefully I can get this working. it would be wonderful to get on my localhost:)
                            • 11. Re: Flex Module Issues
                              johnbarrett1 Level 1
                              I commented out:
                              "Include /private/etc/httpd/users/*.conf
                              LoadModule flex_module "/Users/johnbarrett/flexSamples/flex/modules/mod_flex.so"
                              AddHandler flex .mxml"

                              And now the localhost is running again. Therefore I did not do anything bad to apache, but the flex module is not working, as I knew it would not when I got rid of the code put into it by the flex module. I had some work with ColdFusion that I need to do in the meantime.

                              I really hope I can get this running!
                              • 12. Re: Flex Module Issues
                                Ivascu Cristian Level 1
                                Hi guys,
                                Can you please give us some more details so we can attempt to reproduce it on our test machines? Like the exact Apache version, what other modules involving Java you have (e.g. Jrun) and if you have the developer tools from Mac OS X installed or not.

                                Thanks,
                                Cristian
                                • 13. Re: Flex Module Issues
                                  johnbarrett1 Level 1
                                  Hi,
                                  The site was down before, sorry about getting back to you late
                                  I also have JRun 4, J2EE version (multi-version, not sure what it is called) of coldfusion(under JRun) running on port 80
                                  I do not have the XTools installed

                                  java -version
                                  java version "1.5.0_07"
                                  Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
                                  Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)

                                  Apache/1.3.33 Server at macintosh-3.local Port 80

                                  Thanks,
                                  John
                                  • 14. Re: Flex Module Issues
                                    Zm0ky
                                    Hi,

                                    I also tried to install this on a ubuntu breezy box and i can't pass the:
                                    "Stack Trace:
                                    java.awt.HeadlessException:
                                    No X11 DISPLAY variable was set, but this program performed an operation which requires it."
                                    cause I have no X enviroment.

                                    tried also the -i console ... and it says that this mode is not supported.
                                    how can I install this on ubuntu ? what's the thing with that flex-config.xml ?
                                    • 15. Re: Flex Module Issues
                                      catalinanastasoaie Level 1
                                      Hi,

                                      For the moment in order to install the Flex Module you need to have the X Environment installed. As for the flex-config.xml if you refer to the one that appeared after you have tried to install the Flex Module is the log file generated by the InstallAnywhere.

                                      In the future we might have a manual installer (a zip package with instructions) that can be used in situations like this one where you don't have the X Environment installed.

                                      Regards,
                                      Catalin Anastasoaie
                                      • 16. Re: Flex Module Issues
                                        johnbarrett1 Level 1
                                        does this refer to the mac too? I know I do not have X windows installed. I am not sure if I should XTools. I have not been able to install this on my mac.
                                        • 17. Re: Flex Module Issues
                                          catalinanastasoaie Level 1
                                          Hi john,

                                          We are trying to duplicate your configuration on one of our MAC OS systems in order to duplicate your problem and be able to give you the right solution to your problem. So as soon as we will have an answer we will get back to you and try to resolve your problem.

                                          Regards,
                                          Catalin
                                          • 18. Re: Flex Module Issues
                                            johnbarrett1 Level 1
                                            thanks so much Catalin`-`
                                            • 19. Re: Flex Module Issues
                                              Ivascu Cristian Level 1
                                              Hi John,
                                              I think we found the problem - are you running on a PowerPC based Mac? The compiled shared object was created against an Intel based mac, so it will not work on a PowerPC. From the entire package only the actual Apache module is affected and we have already compiled a new binary for PPC based macs.
                                              Until the next update we have added a note to the wiki for this particular architecture.
                                              Regards,
                                              Cristian
                                              • 20. Re: Flex Module Issues
                                                Ivascu Cristian Level 1
                                                Hi guys,
                                                If you have a PowerPC based Mac you cannot use the Flex Module by default. The Apache module binary that is copied by the installer only works for Intel - based macs. In the next update we will fix this and address both architectures.
                                                In the mean time, if you still want to use the module you should follow these steps:
                                                1. Install the Flex Module for Apache and IIS which you have downloaded from labs. Remember the installation folder.
                                                2. Download the new module here
                                                3. Make sure your Apache is closed. To do this open a Terminal and type: sudo apachectl stop.
                                                4. Unzip the file you've downloaded at step 2 and copy the included mod_flex.so into [INSTALL_FOLDER]/modules. When asked whether to overwrite the existing one choose yes.
                                                5. Start Apache and try out the installer.

                                                Hope this helps,
                                                Cristian
                                                • 21. Re: Flex Module Issues
                                                  johnbarrett1 Level 1
                                                  Hi Cristian,
                                                  I would like to thank you very much for all your help, I really appreciate your help walking me through setting up this flex module for my Mac`-`

                                                  If any body has any issues with this, e-mail me,and I can help out. Since Cristian helped me so much, I would more than happy to help anybody else who is have issues with this.

                                                  John
                                                  • 22. Re: Flex Module Issues
                                                    alpharom
                                                    Hi all,

                                                    I'm trying to install flex_module too.
                                                    I'm using OpenSuse 10.2, apache 2.2.3, java 1.5.0_10 and an IA64 architecture;

                                                    I tried to install flex module thanks to Linux intaller, installation goes rigth but when I launch apache (/etc/init.d/apache start) it answer me it cannot find mod_flex.so. When I search for it, I never find it : the modules folder is not existing in my install directory.

                                                    I've tried both flex_mod_basic and flex_mod_full.

                                                    So i tried to dowload the new version you proposed ( http://flexapps.macromedia.com/labs/module/mod_flex.zip) but when apache start he found it but say :
                                                    Cannot load /*****/flexSDK/modules/mod_flex.so into server: /*****/flexSDK/modules/mod_flex.so: invalid ELF header

                                                    I guess i would need mod_flex.so compiled for IA64 architecture but maybe i made a mistake.

                                                    Thanks for help
                                                    • 23. Re: Flex Module Issues
                                                      matlin72
                                                      Hi!
                                                      I've got the same error as alpharom, also running SuSE 10.2. The arcitecture is IA32 (i guess, cpu is PIII). Studying the log file it ends like this:

                                                      /*****/Flexworks/FlexSDK2/mods
                                                      /*****/Flexworks/FlexSDK2/mods/linux/1x /*****/Flexworks/FlexSDK2/mods/linux/20 /*****/Flexworks/FlexSDK2/mods/linux/22 /*****/Flexworks/FlexSDK2/mods/macos/1x /*****/Flexworks/FlexSDK2/mods/macos/20 /*****/Flexworks/FlexSDK2/mods/macos/22 /*****/Flexworks/FlexSDK2/mods/win
                                                      /*****/Flexworks/FlexSDK2/mods/win/1x /*****/Flexworks/FlexSDK2/mods/win/1x/ /*****/Flexworks/FlexSDK2/mods/win/20 /*****/Flexworks/FlexSDK2/mods/win/22
                                                      /*****/Flexworks/FlexSDK2/iis
                                                      /*****/Flexworks/FlexSDK2/iis/
                                                      /*****/Flexworks/FlexSDK2/lib
                                                      /*****/Flexworks/FlexSDK2/templates
                                                      /*****/Flexworks/FlexSDK2/
                                                      /*****/Flexworks/FlexSDK2/
                                                      /*****/Flexworks/FlexSDK2/
                                                      /*****/Flexworks/FlexSDK2/
                                                      Source file /*****/Flexworks/FlexSDK2/mods/linux/mod_flex.so does not exist. There was a problem creating the RPM package. You may not be running as root or may not have installed RPM Builder correctly. java.lang.NullPointerException /*****/Flexworks/FlexSDK2/compiler.conf /usr/bin/compiler.sh /etc/apache2/httpd.conf class RefreshEnvironment.install() Unexpected Fatal Error:

                                                      I run installer as root and I've installed the rpmbuilder that comes whith the distro, namely krpmbuilder. May this be the problem?

                                                      In the shell from which I started the installer I get three Command.run(): Java.io.IOException error messages. httpd, apache2 and apache not found. According to the installer, It has been successfully installed, inspite of shell error messages.

                                                      Any help is much apreciated
                                                      • 24. Re: Flex Module Issues
                                                        bhaze
                                                        Hey - I can't get the flex module to DO anything in Apache 2.0.59 on PCLOS.
                                                        It loads PHP, mod_speling, rewrite, etc, but when I load a flex page and view source, it's blank. According to logs, apache is actually loading the module and I have the AddHandler in there. I can even use ./mxmlc filename to generate a SWF.. Just never through apache :) And ideas?
                                                        • 25. Re: Flex Module Issues
                                                          Max_Montreal
                                                          Hi - just wanted to add that I also get the problem a few others have mentioned -- when loading an mxml file through a browser, it's blank. No errors in the logs anywhere.

                                                          Running: CentOS 5, Apache 2.2.3, tried with flex SDK 2 and 3. Followed all the instructions rigorously in the readme that came with the manual install for linux. I can compile the sample code successfully by running the build.sh scripts (that is, I can rebuild the swf files in the samples directories by running the build scripts), but when I try to load the mxml files through apache into the browser I just get blank pages; view source also returns a blank page. Happens in both IE and Firefox.

                                                          Any suggestions?

                                                          thanks

                                                          Max
                                                          • 26. Re: Flex Module Issues
                                                            catalinanastasoaie Level 1
                                                            Hi Max,

                                                            The flex module needs write permissions on the installation folder and on the folder where the mxml application is present. Could you verify this on your computer and try to re-test the flex module after setting the needed permissions and restarting the apache server.

                                                            Thanks,
                                                            Catalin
                                                            • 27. Re: Flex Module Issues
                                                              Gavin Renner
                                                              Hi, I'm having an issue getting the flex apache module installer to work under Leopard. The installers launch but then they hang after about a minute and never do anything else. Is this a known issue and is there an update in the works for that? This seems to be affecting the following installer disk images...

                                                              flex_mod_basic_mac_050107.dmg (2.0.1)
                                                              flex_mod_full_mac_050107.dmg (2.0.1)
                                                              flex3compiler_b2_apache_mac_100107.zip (3 beta)

                                                              Thanks in advance,

                                                              Gavin Andrew Renner
                                                              • 28. Re: Flex Module Issues
                                                                Ivascu Cristian Level 1
                                                                Hi Gavin,

                                                                We also found this issue recently - apparently on Leopard the installer crashes with a "Segmentation Fault" in the console when it tries to authenticate the user (if you installed it on a previous mac version you noticed it asking for the administrator username/ password). We have worked on a fix for this and it should be available soon.

                                                                Thanks,
                                                                Cristian
                                                                • 29. Re: Flex Module Issues
                                                                  simonphp

                                                                  Ivascu_Cristian,

                                                                   

                                                                  The link that you provided in step #2 is no longer available. I would like to download the 'new module' as you've mentioned as I am having the exact same problem. Please help.