2 Replies Latest reply on Nov 19, 2014 1:58 PM by vandanacathy

    Adobe Photoshop CS4 won't open in Yosemite. Anything I can do about this?

    vandanacathy Level 1

      After installing Yosemite I was told that in order "To open Adobe Photoshop CS4 you need to install the legacy Java SE 6 runtime.

      Unfortunately I was also told that I needed to upgrade to Java 8 update 25...which I did thinking it would also resolve the Photoshop issue.

       

      Silly me!

      It probably made things worse as far as the possibility of opening Photoshop CS4.

      Now what do I do?

      I don't want to go back to Java 6. Are there any other options?

       

      Thanks.