4 Replies Latest reply on Nov 19, 2014 5:43 PM by Bob Somrak

    I'm looking to buy Lightroom 4 - my computer is not compatible with Lightroom 5. Is this at all possible?

    EMcDonough

      I'm running OS X 10.6.8, and I don't want to upgrade the system as I will lose the ability to run other software I have installed. I would love to use Lightroom to edit my RAW photos, but it seems imposssible to find a place that I can purchase the older version. Can anyone help please?

       

      Thanks!